Zywall USG 110 - VoIP - BLF not working

Spiro
Spiro Posts: 8
First Comment
edited April 2021 in Security

Hi, We have a Zywall USG 110 and have recently deployed a new VoIP telephone system. But we are having a problem trying to get the BLF indicators working on the telephones. The telephones work OK, it is just the BLF that does not seem to be working. We have tried upgrading the USG 110 to the latest firmware, but this made no difference, tried connecting the telephones to the LAN and the DMZ, still not working. We have Enable SIP ALG turned off, is this correct ? If we replace the Zywall with our old router/firewall then the BLF works OK. but if we put Zywall USG 110 back they stop working, so we are pretty sure there is something on the Zywall USG 110 causing this issue.

«1

All Replies

  • jannisb
    jannisb Posts: 11
    First Comment Second Anniversary

    Are the Phones on the same Network with the sip Server? Did they Work before you installed the zywall?

  • Spiro
    Spiro Posts: 8
    First Comment

    Hi Jannis, the VoIP server is in cloud on internet. We have two installations, one at head office where telephones go out through separate gateway and not their Zywall USG 110. But at warehouse we only have one line (fibre to premises) which feeds our Zywall USG 110. Head office telephones BLF is working, they connect to SIP server via Cisco router. Our warehouse telephones connect to SIP server from behind Zywall USG 110 and although telephones work we cannot get our BLF to work, ie people at head office cannot tell if we are 'busy' on the telephone.

  • Spiro
    Spiro Posts: 8
    First Comment

    We took the Zywall USG 110 out and reinstalled our old router and got that going and then the BLF works OK, just seems that something on Zywall USG 110 is not allowing it.

  • Spiro
    Spiro Posts: 8
    First Comment

    Need to have Zywall USG 110 in place though as we use this for IPSEC tunnel to head office.

  • Spiro
    Spiro Posts: 8
    First Comment

    We don't really want to have to put in a second line just for the VoIP telephones.

  • jannisb
    jannisb Posts: 11
    First Comment Second Anniversary

    i Understand.did you also use IPsec with the old router? maybe the old router had also more settings than just the ipsec tunnel to the HQ?

  • jannisb
    jannisb Posts: 11
    First Comment Second Anniversary

    try to use a BLF server setting or set your extension DNS mode from "A record" to "DNS SRV"

    i know it worked with the other router and i m telling you to change your extension settings but there is a chance to solve your problem.

    you will need the zywall 110 logs if you think this router is cutting something out.

  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,210
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member

    Hi @Sprio 

    The BLF working behavior is:

    Client sends “Subscribe” packets to server, and then server replies “Notify” packets to client.

    The subscribed phone number status will exist in XML of message body.

    You can capture the packets on WAN and LAN interfaces together, and make sure if packets have forwarded to client successfully.


  • Spiro
    Spiro Posts: 8
    First Comment

    Cheers guys, I'll look for that. Am I specifically looking for SUBSCRIBE or NOTIFY entries which end with 'transport=udp' ?

  • Spiro
    Spiro Posts: 8
    First Comment
    edited June 2019

    I'm seeing this:

Security Highlight