USG110 - CPU usage is increasing over days

USG_User
USG_User Posts: 172  Master Member
edited April 14 in Security

We experience that the CPU usage increases slowly when the USG is running over a long period without regular restart. I noticed it by checking the daily status report. And yesterday I saw that our CPU is running at 40%. Then I've checked the status reports of the last 14 days and found different days where the CPU usage increased a little bit in steps.

A reboot of the USG seems to reset any running processes and slow down the CPU to 0-6% again.

Is this a normal behaviour that the CPU utilization increases over the time?

«1

All Replies

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 698  Zyxel Employee

    Hi @USG_User,

    This CPU usage 4x% seems to be within the acceptable range. 

    In this case, we need to check which daemon/service is increasing day by day.

    Here we can use cli “show cpu average” to observe that what is the loading for.


    CLI: show cpu average


  • USG_User
    USG_User Posts: 172  Master Member

    Thanks a lot Zyxel_Cooldia. But it seems the CLI box doesn't work correctly with us. I can call the box using the CLI "button" in the top right corner. The box will be opened, but I'm not able to type anything inside. After a short time the box is showing things like:

    [0] show anti-virus statistics ranking virus-name

    ### CLI End 

    [0] show content-filter statistics summary

    ### CLI End 

    [0] show firewall block_rules

    ### CLI End 

    [0] show fqdn

    [1] show version

    [2] show mac

    [3] show serial-number

    [4] show boot module debug status

    [5] show cloud-helper firmware download-status

    [6] show cloud-helper firmware _running

    [7] show cloud-helper remind

    ### CLI End 

    [0] show idp statistics ranking signature-name


    Does the CLI command box need JRE installed too?

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 698  Zyxel Employee

    Hi @USG_User

    The top right button “CLI” that displays the CLI commands sent by the Web Configurator to the Zyxel Device.

    You should click “Console” to enable web console. 

    It’s Java base console, it will prompt you to install JRE.

    Web Console:

    This is how it looks like.


  • USG_User
    USG_User Posts: 172  Master Member

    Hi Zyxel_Cooldia,

    Now I would like to make the Console working. Therefore I tried to install Sun Java 2 SE SDK as adviced by your remark window when clicking onto the Console link in the upper right edge.


    Unfortunately Java 2 SE is soo obsolete that I don't want to install it, especially due to security risks (not longer updated by Oracle). Further there were some licence changings with Oracle Java recently. Please advice what I should install instead for getting the Console usable.

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 698  Zyxel Employee

    HI @USG_User ,

    We will have enhancement on Web Console in Q4/2019 formal release, it's not jave base.

    You also can get the result of CPU usage by ssh access.

  • USG_User
    USG_User Posts: 172  Master Member

    Thanks Cooldia,

    Now we've allowed the access to USG additionally via SSH, but from local LAN subnet only. Works so far.


    Thanks

  • USG_User
    USG_User Posts: 172  Master Member
    Hi,
    Now our USG is running for a while (about a month since last reboot) and now we are experiencing the daily increasing of the permanent CPU utilization again.

    The daily USG report shows the CPU utilization like this:


    Now we've checked the USG processes by using the SSH command "show cpu average". The result is as follows:

    We don't know which process is causing the permanent CPU utilization of 23% at CPU #0 (on a saturday where nobody is working in the office).

    Now we will reboot the USG. This will lead to a CPU utilization not exceeding 4% for the next weeks, except for some single peaks during working days.
  • PeterUK
    PeterUK Posts: 879  Guru Member
    are you running the newest firmware on your USG?
  • USG_User
    USG_User Posts: 172  Master Member
    We are running the V4.33(AAPH.0)
  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 698  Zyxel Employee

    Hi @USG_User,

    The main loading is mainly on content filter. In this case, the loading on CPU is within the acceptable range for now. It’s manageable on USG110.

    You can keep monitor it once the content filter usage is up to around 60~80, just let us know.


Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!