DynDNS

Athena
Athena Posts: 5
edited April 2021 in Security

Hello,

I configured a DynDNS on an USG40.

The IP of the WAN port is correctly forwarded, but... it is the local WAN port addresse (192.168.1.x).

Is it possible to send (to the DynDNS provider) the public IP of the router beyond the WAN port ?

Thanks in advance for your help.

All Replies

  • PeterUK
    PeterUK Posts: 1,403  Guru Member
    edited August 2019

    No the DDNS uses the interface IP as the IP it sends the USG40 must have the WAN IP to send the WAN IP.

  • Athena
    Athena Posts: 5

    OK, thanks for the answer.

    But it won't help...

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 959  Zyxel Employee
    edited August 2019

     Hi @Athena

    When the USG is behind a NAT router, you can set the IP Address to AUTO, instead of Interface.The DDNS server checks the source IP address of the packets from the Zyxel Device for the IP address to use for the domain name. You can set to auto in this scenario, but the options available in this field vary by DDNS provider.

    Create a DDNS profile at “CONFIGUATION > Network > DDNS”, and set to “AUTO” at IP address.


  • PeterUK
    PeterUK Posts: 1,403  Guru Member

    Its too bad No-IP don't have that Auto option.

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 959  Zyxel Employee

    Yes, some DDNS provider does not support Auto option.

  • PeterUK
    PeterUK Posts: 1,403  Guru Member

    Their is a No-IP software client that detects the WAN IP so may be its possible? That or this still would work so that I can link it to OPT but go out VLAN443.

    https://businessforum.zyxel.com/discussion/665/adding-a-ddns-for-ip-address-for-custom-to-link-to-the-address-objects-list#latest

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 959  Zyxel Employee

    Hi @PeterUK ,

    We just found that NO-IP does support IP address = Auto. I will put this thread in idea section.

Security Highlight