DNS Suffix no more working on USG-310 after uprading Firmware at V4.35

Assitek
Assitek Posts: 3
First Anniversary First Comment
edited April 2021 in Security
hello, after the firmware update to version 4.35, the dhcp configuration on the vlan that also distributed the dns suffix stopped working.
has anyone already had this problem?
have you found a solution?

after the update I can't ping the pc inside the main lan from any pc in any vlan without inserting the dns extension in the name ... to understand ping pc1 it goes in failed request, while ping pc1.mydomain.local successfully completes the ping.

until this firmware version, everything was resolved by inserting a string in the VLAN DHCP Advance configuration (name domain-suffix, code 15, type TEXT, Value mydomain.local)

Thanks

All Replies

  • Zyxel_Emily
    Zyxel_Emily Posts: 1,296  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @Assitek,

    It works on both firmware 4.33 and 4.35.

    Here is my test result for your reference.

    If your settings are the same as mine but it is still not working, feel free to share the configuration file with me in private message.


    Configure DNS suffix in vlan11.


    Create an address record.

    Connect PC to vlan11. It successfully gets IP 192.168.19.5 and DNS suffix cso.com. 

    On one PC in LAN, ping “test” successfully.


  • Hy Zyxel_Emily

    the configurations are almost identical


    my problem is that with my pc connected on vlan 4 (wifi) with ip 10.59.3.x I can't resolve the names on the main VLAN 192.168.1.x

    Which before the upgrade to 4.35 worked perfectly

    I am obliged to put the dns extension to resolve the name

    note (I'm doing nslookup on DNS SERVER)

    reverting the firmware to 4.33 everything starts working perfectly again


    Thanks

    Marco

Security Highlight