GS1910-24 and GS1920-24 losing configuration

Jouko Posts: 3
First Comment
edited August 2022 in Switch
I am mildly disappointed and slightly irritated. Some years ago, I purchased a used GS1910-24 switch. Soon after purchase I realized that it worked perfectly except that it lost its configuration at every reboot. Back then it was not an issue for me, as I had nothing I needed to configure in it.

Recently I had to be able to setup a VLAN and as my GS1910 could not save its settings, I needed to get a new router. Stupid as I was, I purchased a used GS1920-24. This one also works perfectly, except that it looses its setup at every reboot, too!

This is incredible. Is this how your products are "programmed to behave" as they get older? And presumably the recyclers/sellers in eBay are happy to take part in the scam by reselling them?!?

Yes, I am pressing the separate "save config" button but it gets me nowhere. Nor is there any battery inside to replace... I now have two routers "kind of" working... The third that I may now need to buy will not be a Zyxel :-(


  • Jouko
    Jouko Posts: 3
    First Comment

    To fill in some details: The switch is a GS1920-24HP with Boot Version V1.00 | 03/21/2014 and Firmware Version V4.50(AAOC.2) | 02/27/2018. I think I have now tried everything I can think of to try and save the configuration. It makes no difference if I use config 1 or config 2. I have factory reset the device several times. Even just performing a reboot from the management console (using either config 1 or config 2 to boot to) makes the router lose the configuration completely.

    And yes, the funny thing is, I have that old GS1910-24HP next to this router and it has exactly the same fault. I could of course source another used GS1920 for a decent price but I feel hesitant to ever touch anything from this product family again... Do you have any ideas?

  • imaohw
    imaohw Posts: 123  Ally Member
    First Anniversary 10 Comments Friend Collector First Answer

    When you press the Save button does the page show that the configuration has been saved?

  • Jouko
    Jouko Posts: 3
    First Comment

    I got this sorted out, finally! For reasons beyond my understanding, the switch only keeps configuration for "Config 1". If set to boot "Config 2", it always boots with factory default settings, despite having saved a modified "Config 2" (via the "Maintenance" page). I originally only upgraded "Config 2" to most recent ROM version, as my idea was to leave "Config 1" intact, using an older version. This was obviously not a good idea. I changed the router to boot "Config 1" instead and then reflashed it to most recent ROM. Both configs are now in the same version and "Config 1" is keeping the saved settings. All sorted out. Now it is time to start tinkering with the VLAN configs...

  • Zyxel小編 Lucious
    Zyxel小編 Lucious Posts: 278  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    edited November 2019

    Hi @Jouko

    There is a configuration checking mechanism when the version gap between firmware image 1,2 is too big (For example: image 1 is 4.10 and image 2 is 4.50) and could lead to default setting to avoid mismatched configuration.

    So it's better to keep both firmware as close or same trunk version to prevent the problem.

    Anyway, glad that you sorted it all out.