GS1900-16 Firmware update

BobStricklin
BobStricklin Posts: 1
edited April 14 in Switch
Having a problem updating firmware on two GS1900-16. When I go to the Web ap page to update firmware the page is not complete. Like it has an issue with Web browser but I have tried several on MAC and Windows.
Also the firmware file 2.60(AAHJ.1)C0.bix I downloaded does not seem like it will work when I try to select this file. Is there another way to upgrade firmware. I tried Zon Utility but this does not find my Zyxel devices after install.

All Replies

  • Zyxel_Derrick
    Zyxel_Derrick Posts: 76  Zyxel Employee
    Hi @BobStricklin

    Welcome to Zyxel community!!
    May I know did you turn off the firewall of your PC?
    If no, please disable the firewall and try again
    Also, may I know the firmware version you are using on GS1900?
    BTW, we will release a new firmware version recently and we suggest installing the latest firmware.
    Thanks

    Best regards,
    Zyxel_Derrick
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!