External captive portal on USG1900: bad format url and page not found after login with Chrome

LALU
LALU Posts: 7
First Anniversary Friend Collector First Comment
edited April 2021 in Security
Hi, I have implemented an external captive portal on USG1900.
I have simulated a new guest that connect to Wi-Fi network for the first time,
so I deleted the browser cache of Chrome.
When the guest call a web site, for example "tio.ch", the USG 1900 redirect to captive login page with the following URL (see image because the forum was correcting my url)

https://www.screencast.com/t/ocYz9SW7YP

We can see that the characters "://" has been converted in %3A%2F%2F

After the login, he receive the following error:

The requested URL was not found on this server.


after this, I logout and call the page "tio.ch" again: 
now the URL seems more readable and correct than the first one.

http://www.domain.ch/login/?gw_addr=http://10.0.8.1:80&error_num=0&mobile=1&ps_display=0&ps_path=&wg_display=0&uag_mac=B8:EC:A3:B4:C0:97&wtp_mac=&client_mac=B4:C4:FC:6C:9F:40&ap_ip=&client_ip=10.0.8.110&ssid_name=&vlan_id=&auth_path=/weblogin.cgi&mp_idx=1598506866990074&original_url=http://tio.ch/weblogin.cgi?mobile=1

After the login the guest are redirected correctly to "tio.ch" website.

With the last EDGE browser the problem isn't present.

This is a bug of CGI script on USG1900 ?

Best  regards 
Luca

All Replies

  • LALU
    LALU Posts: 7
    First Anniversary Friend Collector First Comment
    edited October 2020
    .
  • chandan
    chandan Posts: 72  Ally Member
    First Anniversary 10 Comments Friend Collector
    The current configuration on USG devices allows the internet explorer browser to display the login URL properly. The same is with Web Authentication also..
  • Zyxel_Emily
    Zyxel_Emily Posts: 1,296  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @LALU,

    We use Chrome to redirect to the external web portal successfully even if the redirect URL contains %3A%2F%2F.




    In System > WWW > Service Control > HTTPS, check if “Redirect HTTP to HTTPS” is disabled.

Security Highlight