DNS Forward zone Bug VPN100 V4.60(ABFV.0)

Options
Stef085
Stef085 Posts: 7
First Anniversary First Comment
edited April 2021 in Security

Hi!

Just upgraded to Version 4.6 on my VPN100...
I experienced a not working DNS Zone forward (VPN100 as vpn server) trough my site2site vpn tunnel.

specific dns *.domain.xy should be queried from 192.168.1.3
don’t work in v4.6

I deleted the rule and entered it again, but no change.

 

I rebooted on previous version V4.35(ABFV.3). everything is working fine.
I’ll stay on the old version, until Zyxel reviews and solves this bug.

 

Best regards

Stefan


Comments

  • PeterUK
    PeterUK Posts: 2,876  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    So this is by DNS Domain Zone Forwarder are you use Public DNS server or private DNS server if using private try public by query via the zone of  192.168.1.3   

  • Stef085
    Options
    i checked both...
    it was on privat, but i tuned to public with lan1 zone.. no change..
  • PeterUK
    PeterUK Posts: 2,876  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    So your VPN site2site for VPN100 whats the remote policy IP by and by what device? and local policy 192.168.1.0/24 ?

    What happens if you put * only to forward to DNS server 192.168.1.3 ?

    Do the logs show any blocks from VPN tunnel to LAN1?



  • Zyxel_Charlie
    Zyxel_Charlie Posts: 1,034  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Options
    @Stef085
    The issue has been confirmed, so if any news, will let you know.

Security Highlight