USG 50 error by updating firmware

IVIOJAN
IVIOJAN Posts: 1  Freshman Member
edited April 2021 in Security
We have a firewall usg 50 in our school. The firmware is still 2.21 (BDS.1) I tried to update it but I get an error every time. errno: -42007 errmsg: Firmware content error! Any idea what the problem could be?

Comments

  • Blabababa
    Blabababa Posts: 142  Ally Member
    It's not suggested to jump from very old firmware to the latest. You may try upgrade by following sequence.
    V2.21 => V3.00 => V3.30
    Firmware can be downloaded from the official ftp site and login with anonymous account.
    ftp://ftp2.zyxel.com

  • jasailafan
    jasailafan Posts: 159  Master Member
    Maybe you can try to use firmware recovery to upgrade USG 50 to the latest version. 
    Check Appendix 3. Firmware Recovery in the release note.
  • Mark_Zyxel
    Mark_Zyxel Posts: 118  Zyxel Employee
    edited October 2017
    Dear customer,
    Is it maybe because you tried to flash it with the zip file instead of the bin file.
    (so unzip the (firmware).zip file)
    and use the .BIN file instead.
    kind regards
    M

    👾

  • Johan
    Johan Posts: 27  Freshman Member
    I believe you have received the answers, but compilation:
    1, Backup your configuration, backup your configuration, backup your configuration.
    2, Like Mark said: Make sure you unzip and upload the .bin file, not the .zip.
    3, Like Blabababa said do not jump from such an old firmware directly to the latest one. His/Her suggestion on jumps is good: V2.21 => V3.00 => V3.30. If there are still issues try even smaller increments.

    4, Do not do the upgrade by doing a firmware recovery as explained in appendix 3 in the release notes.
  • Zyxel_Charlie
    Zyxel_Charlie Posts: 1,034  Zyxel Employee
    Hello IVIOJAN,
    Is the issue solved after follow above good suggestion?
    Charlie

Security Highlight