How do I repair my bricked Zyxel NWA1100-NH?

mbradleych
mbradleych Posts: 1  Freshman Member
edited April 14 in WirelessLAN
I'm not really sure how this happened but it's blinking red without any changes. 
-M

#Biz_WLAN_March

All Replies

  • Zyxel_Kelly
    Zyxel_Kelly Posts: 0  Freshman Member
    @mbradleych

    If you have the console cable to connect NWA1100-NH.

    Please refer to below operating procedure to do firmware recovery.

    Topology:

    PC or Laptop (Static IP: 192.168.1.222 / Subnet mask: 255.255.255.0) --------------LAN <Ethernet RJ-45> ------------------NWA1100-NH

     

    SETUP/STEP BY STEP PROCEDURE:

    Steps:
    1. Download the TFTP tool and run it on the laptop.
    2. Connect a laptop wired to NWA1100-NH. Configure a static IP address on the laptop's NIC card. The IP address is 192.168.1.222 and Subnet mask is 255.255.255.0.
    3. Disable Windows Firewall before recovering.


    4. Unzip the image file. For example "V212AASI0C0.bin" for NWA1100-NH.
    5. Unzip the image file. For example " V212AASI0C0" for NWA1100-NH.
    6. Copy two files "mi124_f1e-jffs2"," vmlinux_mi124_f1e.lzma.uImage" to the TFTP server folder.



    7. Connect to NWA1100-NH through a serial port. Setup the serial port for the baud rate 115200, data 8 bit, parity none and stop 1 bit.
    8. Power-on the NWA1100-NH.
    9. Press any key before the prompt counts down to zero.

    ************ Post Result *******************

    POST memory PASSED

    POST uart PASSED

    POST ethernet PASSED

    Hit any key to stop autoboot:  4


    10. Setup the IP address.
    >setenv ipaddr (AP IP address)


    >setenv ipaddr (The laptop's static IP address)


    11. Upgrade the kernel.
    >run lk


    12. Upgrade the filesystem.
    >run lf


    13. Reboot the device.
    >reset

    If you don’t have any console cable on your hand and you tried to do above but the symptom is the same.

    Please contact the local reseller.

  • Ludibubi
    Ludibubi Posts: 4  Freshman Member
    Hi together! I have also the problem, that my NWA1100n is bricked after failed update. So I've searched for a console cable. Can you tell me which one I must use? Seriell to RJ45 or USB to RJ45 or which one?
  • Zyxel_Panda
    Zyxel_Panda Posts: 88  Zyxel Employee
    Hi @Ludibubi

    Your AP is NWA1100-N without NWA1100-NH, right?
    If so, NWA1100-N is a legacy AP which is not supported the console port. 

    Below is how to update the firmware via FTP method on NWA1100-N, please try to do it.

    1. PC connects to NWA1100-N and configure PC's IP in same subnet.


    2. Copy firmware to C:\ and change file name of firmware to ras with no extension.
    For example,
    100AAQ3C0.bin is changed to ras


    3. Open command window on PC to load firmware and its path moves to C:\


    3-1 ftp 192.168.1.2-------------->NWA1100-N IP
    3-2 admin-------------------------> device username
    3-3 1234-------------------------->device password
    3-4 bin--------------------------->transmit data in binary mode
    3-5 put ras -------------> firmware filename

    Please await FW write time done.(LED SYS and WLAN both are green)

    Thanks!

     

  • Ludibubi
    Ludibubi Posts: 4  Freshman Member
    Hi! Thanks for reply. I tried this without success. I think the problem is that the AP is bricked and so the interface is not reachable because it doesn't recognize the IP-adress and cannot answer. Any other idea?
    Regards Ludgdr
  • Zyxel_Panda
    Zyxel_Panda Posts: 88  Zyxel Employee
    Hi @Ludibubi

    Please run the RMA process with local agent.
    But actually this legacy AP is EoL for a while.
    I think the warranty period should be expired too.
    Thanks!

  • Ludibubi
    Ludibubi Posts: 4  Freshman Member
    What do you mean with "run process with local agent"?
  • Zyxel_Panda
    Zyxel_Panda Posts: 88  Zyxel Employee
    Hi @Ludibubi

    I mean where did you purchase this product ? from any distributor or agent?
  • Ludibubi
    Ludibubi Posts: 4  Freshman Member
    My boss gave it to me because we don't need it anymore in our company. I don't know wäre it was purchased.
    Regards Ludger