GS1200-5 changed hardware mac-address in the LAN by itself

Uwe Posts: 4  Freshman Member
edited August 2022 in Switch
My LAN consists of 2 GS1200-8 and 2 GS1200-5.  At the beginning, all works fine. 
Now, I get an loop indication on one of them. It seem, that one switch takes over the mac from another switch. Now there are two switches with the same hardware mac.

Reset on Factory Settings did not help. I also installed the firmware again, no change. 

Does anybody knows, how to change to individual addresses?



All Replies

  • Penny
    Penny Posts: 65  Ally Member
    Can you share the firmware version of GS1200-5 and GS1200-8?
    And may I know your network topology?

    // Now, I get an loop indication on one of them.
    -> Where do you saw this?

    // It seem, that one switch takes over the mac from another switch.
    -> GS1200-5 MAC is changed as GS1200-8 MAC or GS1200-8 MAC is changed as GS1200-5 MAC? How do you check this? Is there any screenshots?
  • Uwe
    Uwe Posts: 4  Freshman Member

    GS1200-5: V1.00(ABKM.0)C0
    GS1200-8: V1.00(ABME.0)C0

    Topology is at follows:

    PV-Inverters                       div clients                               div clients                    WLAN-Ap,Energy-meter
    |  |  |  |                                        |  |  |  |  |  |  |                                 |  |  |  |  |  |  |                      |  |  |  |
    GS1200-5 (A)  <-------->GS1200-8 (B) <-------->GS1200-8 (C) <-------->GS1200-5 (D)
    dhcp                                        dhcp                                                              dhcp                                                                                    
                                                                                                       debian server

    At the beginning, every device could be connected via http using the estimated IP

    Later, only (C) could be reached. When I disconected (D), (B) was able to be connected.
    (B) an (D) does now have the same MAC.  (D) has changed.

    Now, (D) replaced by dlink-switch, (A) is still not be able to connect.
    (B) gave an indication on the first screen "loop".
    Then I changed on the port-window from "loop-prevention" to "loop detection" and Flow Control of the Portfrom (B) to (A) "Enable". Then loop-indication get cleared. (A) ist still not reachable.

    MAC from (D), was taken from (B)
    I checked it by direct connection between laptop and (D) without any other connection.
    Later, I download the firmeware on the GS1200-5 again, connected from MAC was unchanged.


  • Penny
    Penny Posts: 65  Ally Member
    edited August 2018
    As you mentioned, (B) gave an indication on the first screen "loop". You should check the connection of your network to find out the root cause about loop problem.

    In my view, it seems the devices which connected on (D) to occur loop in your network to cause this problem. So, (D) has changed MAC address as (B) MAC address? Where do you check (D) MAC address?

    May I know is there any device connected to WLAN-AP via Ethernet cable? And is possible to provide more information about your network topology?

    Do you try to reset 4 GS1200 switch? And then, only connected (A), (B), (C) switch to check this problem first?
  • Hill
    Hill Posts: 156
    First Comment Fifth Anniversary
     Master Member
    edited August 2018
    Your environment has loop problem. When Switch detect "loop", it will block that port to cause you cannot access some Switch. That port becomes active when the loop disappears.

    Loop Detection allows the switch to discover a loop if it happens.
    Loop Prevention allows the switch to shut down a port automatically if it discover a loop on that port.
  • Hi all, 
    I want to come back to the main topic of the thread. 
    My Zyxel GS1200 5 had the same behavior as Uwe mentioned.
    For the first few days everything works fine. My dhcp server recognize the switch with following mac and vendor name: b8:ec:a3:96:c1:cc (Zyxel Communications Corporation)

    a few days later the switch got a new ip-adresse, and I wonder why. Now it is a different mac and vendor:
    02:01:06:00:f7:fe (Tews Datentechnik GmbH(local-0))

    any ideas what it is?

  • Teemo
    Teemo Posts: 55  Ally Member
    Hi AndyE,
    What is your detail topology and GS1200-5 firmware?
    If you reboot GS1200-5, is it still the same?
    May I know how to reproduce this problem?
  • Hi Teemo,

    the Firmware it the V1.00(ABKM.0)C0.

    The Switch is connected to a wlan access point and two ip-phones. 

    after a reboot it is still the same. 

    But I can try to make a factory reset... 

  • After a Factory Reset it is also the same...
  • Teemo
    Teemo Posts: 55  Ally Member
    edited September 2018
    Hi AndyE,

    Do you mean: after reset GS1200-5, its MAC Address still is "02:01:06:00:f7:fe"? (Tews Datentechnik GmbH(local-0))

    Many I know do you enable or disable DHCP client?

    If you checked GS1200-5 MAC Address via its Web GUI? Is it change? Or how do you know GS1200-5 MAC Address has changed?

    Is possible to provide some screenshots about this situation? And share more information?
    About your topology, is it such as Internet---Router---GS1200-5---Two IP Phones? Or ...
    I will check it on my side.

  • Andye
    Andye Posts: 8
    Nebula Gratitude Third Anniversary
    edited September 2018
    Hi Teemo,

    thanks for your help. I will try to provide as much information as I have.

    Find attached 2 pictures of the webgui.

    Yes, I have enable the Dhcp Client.
    And yes, the MAC adress is still the same after reset.

    I can see the mac-address and ip-address in my dhcp server on my router. And thats the way how I realise that the mac address had change.

    my topology is like this: router-> switch GS1900 -> AP WAC6103->switch GS1200->two snom IP-Phones.

    I hope this information will help you.
    thanks in advance.

    br andy