Bricked ZyXEL GS1900-24E after FW upgrade

pszabo Posts: 2  Freshman Member
First Comment
edited August 2022 in Switch

I have just upgraded the FW on my ZyXEL GS1900-24E from v. 2.20 to 2.30.

After the FW upgrade went through, the switch rebooted and since then the management web interface is not accessible anymore - neither using the custom IP from the configuration, nor the default

However, the basic switching capabilities of the switch are present, and the devices connected to it are able to communicate over the network.

I have tried to reboot the switch again, also reseting the configuration using the tiny HW button did not make any change.

Is there anything else I can do to make my switch manageable again?

Thanks a lot!



  • pszabo
    pszabo Posts: 2  Freshman Member
    First Comment

    I have already managed to solve my problem.

    Seems with the new FW, the device started to get it's IP from the DHCP instead of using the default hardcoded one.

    I have installed the ZON Utility and used it to discover my device and found out it's still there, but listening on a different IP.
  • newtype
    newtype Posts: 29  Freshman Member
    First Anniversary SurveyFeedback-2022-Mar Nebula Gratitude Friend Collector
    good to share ~ i almost forgot it happened to me once, and took me a while to figure it out ~~
  • JasonTsai
    JasonTsai Posts: 104  Zyxel Employee
    First Anniversary ZCNE Nebula Level 1 Certification - 2019 Friend Collector First Comment
    Hi @pszabo,

    Welcome to Zyxel community!

    I am glad to hear that your problem is resolved by using ZON Utility.

    The root cause of your problem is that it is an original mechanism for GS1900 series:
    If the switch connect to a network which have a DHCP server in when rebooting from factory default, it will request for DHCP IP rather than using the default IP address 

    This mechanism make the user can configure the switch faster after reseting the switch to default in a DHCP environment from remote site.

    I have also tried to reproduce your problem by the following procedure:
    1. Access GS1900-24E which is default configuration (IP address, firmware version V2.20).
    2. Change the IP address to
    3. Firmware upgarde to V2.30 without saving the configuration, click "Yes" to reboot the switch after uploading the firmware.
    4. The IP address change to DHCP IP after reboot.
    I suspect that maybe you did't save the configuration before firmware upgrade.
    Please remember to save the configuration after changing some settings or before firmware upgrade.

    Hope it helps.
  • CrazyTacos
    CrazyTacos Posts: 53  Ally Member
    First Anniversary Friend Collector First Answer First Comment
    You should try using ZON. It made managing their web smart switches so much easier. And best of all, it's free!