GS1900-24 Firmware Issues

Amodin
Amodin Posts: 4  Freshman Member
edited August 2022 in Switch
The past two times I've updated my two switches (GS1900-24) I have noticed that if you have link aggregation turned on for Port 25 and 26 (the fiber ports), when you apply a firmware update and reboot the switches appear to do something similar to a broadcast storm and literally freeze up.

The only course of action that can be taken is to unplug one of the fiber connections and switches appear to recover.  However, once you get into the configuration and look at link aggregation, the configuration no longer shows aggregation and has to be set up again. 

I've also noticed at one time when I updated firmware, it even reset my user/pass information back to default.  Since the 2018 firmware update, it stopped doing that and was not a problem with the 6/27/2019 firmware either.

So why does a firmware update reset link aggregation and cause these switches to literally stop responding?


#Biz_Sep_2019
«1

All Replies

  • Zyxel_Derrick
    Zyxel_Derrick Posts: 126
    5 Answers First Comment Friend Collector First Anniversary
     Zyxel Employee
    Hi Amodin

    Did you save the configuration before upgrading the firmware?
    If no, after upgrading the firmware, the configuration will return to the last configuration that you have saved
    Thanks

    Best regards,
    Zyxel_Derrick

  • Amodin
    Amodin Posts: 4  Freshman Member
    That would explain the second issue I had with regards to the default user/pass issue I ran across, but not the link aggregation issue, as I had saved the configuration on both switches.  When firmware is updated that link aggregation gets lost and I have to physically disconnect the second fiber port to literally free up the network and whatever traffic is being generated.
  • Zyxel_Derrick
    Zyxel_Derrick Posts: 126
    5 Answers First Comment Friend Collector First Anniversary
     Zyxel Employee
    Hi Amodin

    We can't reproduce your issue locally
    Therefore, could you tell us which firmware version you are using?
    Also, which firmware version you upgrade from?
    If possible, could you provide switch's config to us?
    Thanks

    Best regards,
    Zyxel_Derrick
  • Amodin
    Amodin Posts: 4  Freshman Member
    I had the original firmware from 2017, V2.40(AAHL.0) | 11/14/2017.  I am updated to V2.40(AAHL.2) | 06/05/2019.  I had updated from one in between these, and that's when I first noticed this (V2.40(AAHL.1)_20180705 | 07/05/2018).

    I can send the config, the link aggregation is about the most complex thing I have right now.  :)  Just let me know where you send them (I have two switches, and both configs, which are the same really).


  • Zyxel_Derrick
    Zyxel_Derrick Posts: 126
    5 Answers First Comment Friend Collector First Anniversary
     Zyxel Employee
    Hi Amodin

    You can directly PM me the config
    Also, could you describe your procedure of upgrading the firmware?
    Thanks for your help in advance

    Best regards,
    Zyxel_Derrick 
  • Amodin
    Amodin Posts: 4  Freshman Member
    PM sent.  Thanks for any assistance.
  • Marcelo
    Marcelo Posts: 2  Freshman Member
    I have a GS1900-48HP - V2.40(AAHO.0) | 11/14/2017. When I updated the firmware to the latest version, I couldn't get this switch to talk to the other switches. So I had to install an old version of it and the https can't be activated again.
    The network I have consisted of 5 Switches and I want to update one at the time to not impact the whole company.
    Could I update on at the time?
  • dugnizetru
    dugnizetru Posts: 4  Freshman Member
    LACP is broken in all recent firmware versions.

    Last working version: V2.40(AAZI.1)_20180705
    V2.40(AAxx.2)C0 and all newer versions are broken.

    I contacted the Zyxel support with a detailed description and logs about this problem almost a year ago when V2.40(AAxx.2)C0 was released. They completely ignored the problem, claimed that their firmware didn't have any bug and then kept sending the same unrelated generic questions and procedures again and again (via different 1st line support persons) and ignoring all points related to the LACP bug...

    So yes, you shouldn't expect to use LACP on the GS1900 switch series even though it is clearly marketed with this feature... Because Zyxel does not care if you cannot use your product, as long as you have already paid for it...

    My only advice: never buy any Zyxel product again!
  • Zyxel_Derrick
    Zyxel_Derrick Posts: 126
    5 Answers First Comment Friend Collector First Anniversary
     Zyxel Employee
    edited July 2020
    Hi @dugnizetru

    Sorry for any inconvenience
    As you can see, we will respond all the questions on this forum and help users to figure out the problem.
    Therefore, could you provide the information about the problem you have to us again so we can help you to check it?
    Thanks

    Best regards,
    Zyxel_Derrick
  • dugnizetru
    dugnizetru Posts: 4  Freshman Member
    edited July 2020
    Hello @Zyxel_Derrick,

    I'll try one last time to provide information about this bug.

    Network info:
    • Link aggregation with 3 interfaces between Zyxel switch and a router
    • Link aggregation is using LACP
    • LACP traffic is captured on the router
    • Zyxel switch MAC address: b8:ec:a3:xx:xx:xx
    • Router MAC address: fe:e1:ba:xx:xx:xx

    Working LACP with firmware V2.40(AAZI.1)_20180705



    All 3 interfaces are active on the switch:
    GS1900# show lag<br>Load Balancing: src-dst-mac-ip.<br><br>&nbsp;Group ID |&nbsp; Type&nbsp; |&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Ports<br>----------+--------+----------------------------------------------<br>&nbsp;&nbsp; 1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; |&nbsp; LACP&nbsp; |&nbsp; Active: 1-3

    LACP exchange captured on router during switch reboot:
    02:32:44.354807 b8:ec:a3:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Activity, Aggregation, Default]<br>&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System 00:00:00:00:00:00, System Priority 32768, Key 1000, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Timeout, Aggregation, Collecting, Default]<br>&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp; &nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0<br><br>02:32:44.362662 fe:e1:ba:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System fe:e1:ba:xx:xx:xx, System Priority 32768, Key 6, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Activity, Aggregation, Synchronization]<br>&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Activity, Aggregation, Default]<br>&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp; &nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0<br><br>02:32:44.472654 fe:e1:ba:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System fe:e1:ba:xx:xx:xx, System Priority 32768, Key 6, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Activity, Aggregation, Synchronization]<br>&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Activity, Aggregation, Default]<br>&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp; &nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0<br><br>02:32:45.354877 b8:ec:a3:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Activity, Aggregation]<br>&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp; &nbsp; System fe:e1:ba:xx:xx:xx, System Priority 32768, Key 6, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp; &nbsp; State Flags [Activity, Aggregation, Synchronization]<br>&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp; &nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0

    The Zyxel switch correctly detects the router partner, and goes into synchronization state.


    Broken LACP with firmware V2.50(AAZI.0)



    All 3 interfaces are Inactive on the switch (LACP standby mode):
    GS1900# show lag<br>Load Balancing: src-dst-mac-ip.<br><br>&nbsp;Group ID |&nbsp; Type&nbsp; |&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Ports<br>----------+--------+----------------------------------------------<br>&nbsp;&nbsp; 1&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; |&nbsp; LACP&nbsp; |&nbsp; Inactive: 1-3

    LACP exchange captured on router during switch reboot:
    02:39:44.262789 b8:ec:a3:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Activity, Aggregation, Default]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System 00:00:00:00:00:00, System Priority 32768, Key 1000, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Timeout, Aggregation, Collecting, Default]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0<br><br>02:39:44.269710 fe:e1:ba:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System fe:e1:ba:xx:xx:xx, System Priority 32768, Key 6, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Activity, Aggregation, Synchronization]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Activity, Aggregation, Default]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0<br><br>02:39:44.389699 fe:e1:ba:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System fe:e1:ba:xx:xx:xx, System Priority 32768, Key 6, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Activity, Aggregation, Synchronization]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Activity, Aggregation, Default]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0<br><br>02:39:45.262777 b8:ec:a3:xx:xx:xx > 01:80:c2:00:00:02, ethertype Slow Protocols (0x8809), length 124: LACPv1, length 110<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Actor Information TLV (0x01), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System b8:ec:a3:xx:xx:xx, System Priority 65535, Key 1000, Port 1, Port Priority 1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Activity, Aggregation, Default]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Partner Information TLV (0x02), length 20<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System 00:00:00:00:00:00, System Priority 32768, Key 1000, Port 1, Port Priority 32768<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; State Flags [Timeout, Aggregation, Collecting, Default]<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Collector Information TLV (0x03), length 16<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Max Delay 0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Terminator TLV (0x00), length 0

    As you can see, with the new firmware, the Zyxel switch never goes into synchronization mode, it never acknowledges the LACP packets from the router which have the Synchronization flag.

    The Zyxel switch keeps sending packet with partner's state flags "Timeout, Aggregation, Collecting, Default" and no partner MAC address. This means that the Zyxel switch never process the LACP packets sent by the router.

    To avoid being asked the same questions your support already asked 20 times:
    • Yes I've rebooted the switch multiple times.
    • Yes I've done a factory reset and reconfigured from scratch with the new firmware.
    • Yes I've tested with different routers and switches. The problem is clearly comming from the Zyxel switch as shown in the above packet capture.
    • No I won't give you my full name, address and phone number, I don't see how this information is going to help you fix this bug...

    If you have questions relevant to this bug, and that your goal is really to fix it, don't hesitate to ask.