Help! Zyxel GS1900-24HP is shown as Zyxel GS1900-8

fleptin
fleptin Posts: 1
edited April 14 in Switch
Hey,

I got a used Zyxel GS1900-24HP switch and had troubles for initial configuration. I pressed reset button to get factory defaults and tried with my laptop wired connection to configure. But I got no link for my ehternet-interface or it was only working for some seconds after power on the switch, than the link got lost.

I didn't want to give up, so I opened the switch and have seen a 10pin-connector on the mainboard and identifed a chip nearby. I googled for the chracters on the chip, and so I could it identify this chip as a RS232 controller. Now I was cabling the 10pin-connector to my laptop and got console access with tera term.

So I logged in (defaults admin/1234) after boot up and tried the interface commands, there was no higher port number than 16 accepted. So I recognized, that in my early tests I tried only port numbers 20 to 24 to get a link.

The I connected at port 10, I can access the web interface at 192.168.1.1 (my laptop has 192.168.1.111). But, I was very surprised that the Zyxel switch is shown as a GS1900-8 at the web interface, and there are also shown only Ports 1 to 8.

But in fact it is a GS1900-24HP. I updated to newest firmware 2.50(AAHM.0)C0.bix, but it didn't help. Update was successful, I see this message at console:

========= NOTE: HTP test failed, "ctrl+c" to continue =========

## Booting image from partition ... 0
   Version:   V2.50.0
   Created:   2019-10-21  15:23:59 UTC
   Size:      6428671 Bytes = 6.1 MB
   Verifying Checksum ... OK
   Uncompressing Image ... OK

Starting ...

--------------------------------------

I don't know what "HTP test failed" means, and I can see the firmware update to V2.50.0 was successful.

But it is still shown as GS1900-8 in the web management ...

There are a lot of commands possible to use before booting (Press SPACE to abort boot script)  when i press Space at the given moment.

But Zyxel doesn't support console access offical and the internal RS232 port is not documented, how to reconfigure firmware issuses a.s.o.

Can anyone help me, how I can learn the switch, that it isn't a GS1900-8 and get to know, that it is a GS1900-24HP?

Kind regards,

fleptino!


#Biz_Feb_2020

Comments

  • Zyxel_Derrick
    Zyxel_Derrick Posts: 76  Zyxel Employee
    edited March 2020
    Hi @fleptin

    Good day
    It seems like this device may have some issues.
    Therefore, please send it to local reseller for repairing.
    Thanks

    Best regards,
    Zyxel_Derrick