Many problems with USG40W and 4.30 Firmware

bananasplit
bananasplit Posts: 3  Freshman Member
First Comment
edited April 2021 in Security
Hi,

I am using a ZyXEL USG40W in my homeoffice since about 2 months with basic configuration. 
One WIFI to lan1, guest WIFI to LAN2, internet dialup via pppoe, 2 portforwardings - nothing special
Since the firmware 4.30 I have extreme performance issues and problems with wifi.
I have 150/20 Mbits Internetconnection

- when I download something with about 100mbits, there is no other connection possible, the CPU goes up to 100% (I thought there is 400mbps Firewall throughput). This problem occurs with and without BWM.

- Every hour I see in the logs: "Port 2 is down", 3 seconds later "Port 2 is up"
That occurs with every port and I have also changed the cable to my computer. Also tried with another device 

- Wifi is sooo instable, once a day there is no possibility of connections via wifi. Mostly when there is more traffic for a while. I can only wait to the next day and it is working again or reset the USG

-Wifi Speed is poor. Only about 20 Mbps over 2,4Ghz and every channel I've tried, about half a meter away of the USG.

- When I connect a LTE/4G Stick (MF823 or E3276-150s -> as supported in the list) the USG reboots and dont come up till I remove the stick and switch off and on.

Please help what to do. I'm thinking of changing to another vendor. I was so happy with the USG20W, but this one is absolut crap.

Next I will try to downgrade to 4.20 this night

thanks in advance

Comments

  • Blabababa
    Blabababa Posts: 151  Master Member
    First Anniversary Friend Collector First Answer First Comment
    I think the previous version should be 4.25 but not 4.20. So didn't you meet those problems in previous versions (4.20 or 4.25) but only on 4.30?
  • bananasplit
    bananasplit Posts: 3  Freshman Member
    First Comment
    Yes,
    I got the USG with 4.20, updated to 4.25 but got the problems with the LTE/4G Stick. Then 4.30 and with this version the most problems
  • Zyxel_Charlie
    Zyxel_Charlie Posts: 1,034  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Hello bananasplit,
    To analyze the case of CPU goes up to 100%,
    we need you to collect Diagnostic info after the issue happened.

    Go to Diagnostics, Press collect now.(Wait for 3~5 mins). Download the files from Diagnostic files field.

    Moreover, for the issue of dongle(LTE/4G), since we cannot reproduce locally, please follow the below steps to collect the log message during the issue occur.  

    1. On tera term, please Go to File>Log>Click Save



    2. Insert the dongle to USG, and stop to gather the message after the issue appear.


    Charlie

  • bananasplit
    bananasplit Posts: 3  Freshman Member
    First Comment
    Hi Charlie,

    I've changed the LTE dongle to a LTE Router via RJ45 and OPT Port - this works without any problem so there is no need to solve this problem anymore.

    About the 100% CPU load I've noticed that it only occurs when I download something will full bandwith of 150Mbit/s. The problem is that in this time I cannot use the DNS server of the USG - my clients get the USG IP for DNS, USG uses public DNS servers. I tried to challenge with BWM but this does not help.
    I will check that with getting a diagnostic file and upload it to zyxel

    best regards

Security Highlight