Configuring NAT for webserver Zyxtel VMG8924-B10D (Tiscali provider - FTTH )

Options
Reijiro
Reijiro Posts: 3  Freshman Member
edited October 2020 in Smart Home Product
Hi all! I have on my net a home web server for testing purposes. I've configured DNS for web access but when I try to config NAT from DNS I see the router login page.
 Web server address is 192.168.1.163 and this is the NAT configuration: 



Also I've trying to use the application tab with the default config for web server but don't work.
It's possible to set up it?

Comments

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    I don't see what DNS has to do with it.
    Anyway, are you testing from inside or from outside? Don't know if your router supports loopback (accessing the external IP address from inside). So it's possible it only works from outside.
  • Reijiro
    Reijiro Posts: 3  Freshman Member
    Options
    I set up a DNS, not having a static IP, to allow customers to see previews of the work. The idea is, therefore, to redirect requests from the outside to the internal webserver.

    From outside i don't see home of web server but the login router page.
  • NeAl
    NeAl Posts: 77  Ally Member
    First Anniversary
    Options
    Port 80 is used by default by modem web gui. I'm not sure  you can change that on a Tiscali-locked modem.
  • Reijiro
    Reijiro Posts: 3  Freshman Member
    Options
    In the applications tab of NAT, it's possible to add an application with default configuration and there's webserver config. I've been trying it but nothing resolving.


    If there's a default config for webserver I think it possible to do .. perhaps I been wrong with WAN Interface?
  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Of course the webinterface of the router is not supposed to run on the WAN. If you remove your portforwards, do you still see the firmware interface from outside?
  • NeAl
    NeAl Posts: 77  Ally Member
    First Anniversary
    edited October 2020
    Options
    You could check in Management/Remote management: port 80 shoud be in use.
    Anyway, I'm not sure you can either access and/or modify that page on a Tiscali-branded modem.
  • TiggerLAS
    TiggerLAS Posts: 64  Ally Member
    First Anniversary First Answer First Comment
    Options

    Generally, you don't want to use port-forwarding to forward an incoming port,
    to the same port on your LAN.

    Try placing your internal webserver onto a different port, such as 8080, for example.
    Then change your port forwarding rule "Mapped port" to 8080, and try it again.

    Alternately, some dynamic DNS providers will let you specify a specific port number
    for your website. . .   if so, change it to something other than 80.
    Example:    mywebserver.dynamicdns.com:9191

    Then on your router, map your incoming port 9191 to your internal webserver at port 80.

    See example from DYN, in the link below. . .



    You may need some combination of both, to get it to work correctly.

Consumer Product Help Center