Suddenly can't use either of my Zyxel switches when connected to my home DSL router

bitoclass
bitoclass Posts: 2
edited April 2021 in Switch
I've been in contact with support for my TP-Link router because I have tried two different Zyxel switches which were both working before and have both stopped working now so I assume it was a problem with the TP-Link router, but they have said I should check with Zyxel as well, so here I am!

I drew them this diagram to explain my problem:



The two Zyxel switches in question are an old 10/100Mbps ES-108A and a newer 1Gbps GS-108S. The problem is the same as shown in the diagram with either of these switches connected to the router.

What is so weird is that this setup was all working perfectly until a few weeks ago and had been for months.

Can anyone suggest what would suddenly mean all the devices on the switch would suddenly go offline like this?

Thanks,
Paul

All Replies

  • TiggerLAS
    TiggerLAS Posts: 63  Ally Member

    Which LAN port on the VR2800 are you using with the Zyxel switches?
    If you're using LAN4, try moving the Zyxel switch over to LAN2 or LAN3,
    and see if the problem still persists.

  • PeterUK
    PeterUK Posts: 1,306  Guru Member

    Try a old firmware on the router.

    If you setup PC A and B to a static IP can they connect to each other or connect to the internet?


  • Same problem here but mine stopped working on January 26
  • Hi everyone,

    Sorry, I didn't get notified of the original responses to this so I thought no-one had replied until tonight's comment appeared.

    Weirdly it started working again without me doing anything, other than swapping back to the original Zyxel switch that was there and stopped working in the first place - I had swapped between the two Zyxels a few times and nothing had changed but then I swapped back yet again a week or so later and this time the newer 1Gbps GS-108S worked fine just like it had done before.

    From some logs of network processes it seems the problem first struck on 31 Dec or 1 Jan, not sure if it was anything to do with the date changing?!

    To answer the suggestions above, I had tried the switch going into multiple different ports and nothing changed. I had not tried setting static IPs on computers A/B/C and seeing if they could see each other or the internet but I will be sure to give that a go if this ever reoccurs. But hopefully the problem has now gone away for good, as inexplicably as it arrived!

    Thanks,
    Paul
  • Zyxel_Jason
    Zyxel_Jason Posts: 369  Master Member
    Hi All,

    Just an information for you to reference that GS-108S and ES-108A are unmanaged Switch which has only pure L2 traffic forwarding.

    @GaryLiou
    If you encounter the similar problem, you may try to setup static IP on those PCs first like @PeterUK mentioned for troubleshooting.

    Thanks.
    Jason