Zyxel 1200-8 Firmware upgrade

Mr_Wrong
Mr_Wrong Posts: 3
First Comment
edited August 2022 in Switch
I just got a Zyxel 1200-8 POE v.2 switch and I am trying to update the firmware to version 2.00.  When I enter the firmware upgrade page and click path to select the firmware, it populates the text box with C:\fakepath\firmware_name and fails when I click update.  If I type the path and name of the firmware and click update it does nothing. I have tried multiple browsers and paths and it never works.  How do I update to the latest firmware?

Accepted Solution

All Replies

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,617  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    HI @Mr_Wrong,

    Welcome to ZYXEL community.

    In order to solve your issue, I would like to ask questions as below:
    1. May I know if your device is GS1200-8HPv2 ?
    2. Were you use the V2.00(ABMF.0)C0.bin file to upgrade? Kindly remind the download file need to be unzip before upgrade.
    3. If you still have same problem, you may try the hotfix version which we fixed an issue related to management vlan. The link is following: https://community.zyxel.com/en/discussion/9591/fixed-gs1200-8-8hpv2-management-ip-address-issue#latest

    Hope it will help.

    Zyxel Melen

  • Hi, thank you for your reply.  I am trying to update a GS1200-8HPv2.  I did unzip the file and attempt to update using the GS1200-8_V2.00(ABME.0)C0.bin file.

    I downloaded the files from the other link that you sent but the problem is that when I browse to select the file it always shows up as <drive_letter>\fakepath\<firmware_name>.  However, this time when I placed it at the root of my drive and typed in the path and updated, it worked.  That did not happen with the other firmware.  I've included a screenshot of the issue I was having below.  It shows what was populated in the Firmware path after I selected the file at the root of my C: drive.  I tried edge, chrome and firefox all had the same issue.

    Thanks for the help!