USB Storage not in use

chandan Posts: 70  Ally Member
edited April 2021 in Security
Hello zyxel team,

What is the minimum & maximum USB storage can be used with Zyxel USG110?
In my case, I have tried to use 8 GB pen-drive with FAT-32 format. But it did not work. 
Please see the error below. 

And why a 8 GB flash drive is showing as 2048.0 GB (2TB). 

However, a 16 GB pen-drive is working properly.

Note: I have tried 3 other pen-drive of same capacity i.e. 8 GB from different manufacturer and the error is same as above. I think this is a bug in the firmware and needs to be rectified.

Best Answers

  • Zyxel_Emily
    Zyxel_Emily Posts: 896  Zyxel Employee
    Answer ✓

    Hi @chandanps18,

    The partition type “0xEE”of your USB storage is not supported.

    We support partition type of FAT32 is “0x0B” or “0x0C” only.

    We suggest you find another USB storage with the supported partition type to use on USG110.


    The following partition types are not supported by USG.

    0xEE: GPT protective MBR

    0xEF: EFI system partition

All Replies

  • chandan
    chandan Posts: 70  Ally Member
    Hi @lalaland

    Thanks for your reply.
    The file system is formatted with FAT32 only and for sure I am not committing such silly mistake before posting it into the public forum.

    These flash-drives (all 8GB pendrives) are working properly in PC without any issue.
    But it is not working with USG device.

    Anyway, I will try with Minitool Partition software and let you know after..
  • chandan
    chandan Posts: 70  Ally Member
    No the result is still same

    Router# show usb-storage
    USBStorage Configuration:
    Activation: enable
    Criterion Number: 100
    Criterion Unit: megabyte
    USB Storage Status:
    Device description: SanDisk Cruzer Blade
    Usage: 2048.0GB
    Filesystem: unknown
    Speed: USB 2.0 480Mbps
    Status: Unused
    Detail: OutOfSpace

    As I told earlier the issue is having only with 8GB pen drive (3 no of 8GB pendrive shows the same information posted above i.e. 2048GB, OutOfSpace and all), so needs to check again from the developer.
  • chandan
    chandan Posts: 70  Ally Member
    Hello @Zyxel_Emily

    Thanks for the info.
    Yes, the disks were initialized as GPT and the file-system was formatted as FAT32.

    After successfully converting it to MBR and formatting the file-system to FAT32, the USB storage is accessible to the firewall.

    Note: Please modify the firewall guide (available in the website) and make a note of this i.e. the USB storage device should be initialized as MBR but not as GPT.

  • dama
    dama Posts: 1
    Use Rufus to format the drive. Set it to non bootable. Rufus can be found on Portableapps The other settings are locked. Click start. Only method that has worked for me.

Security Highlight