Router bricked after firmware update

TheaE Posts: 1
edited December 2018 in Home Router
My NBG6515 was bricked today after upgrading firmware to the newest available version. 
Currently only the power LED comes on, I tried using the reset button following the procedure in the user guide, didn't help. Router is not working in any mode (repeater/router/AP). Plugging an Ethernet cable from router to PC, connection light comes ON but no IP address is assigned to PC, tried assigning address to PC in the range of 192.168.1.x manually and couldn't ping the router on either .1 or .2 address.
Was wondering if there is another procedure to restore the firmware? maybe via USB or using some application that can access the router over some different protocols?
Please help.
Happy holidays to all.


Accepted Solution

  • Zyxel_Steven
    Zyxel_Steven Posts: 247  Zyxel Employee
    edited December 2018 Answer ✓

    We have contacted you via private message. Please kindly check your message box.

Consumer Product Help Center