GS1920 multiple VLAN's over 1 port

PSUPT
PSUPT Posts: 1
edited April 14 in Switch
I have the following setup and I can't seem to get my guest AND private SSID's to work. i'm 100% sure it's on the switch. 





I know my port1 and port10 need to be configured in a way that both vlan's should go over them but the PVID in the PORT CONFIGURATION only allows 1 PVID. 

How would I let this topology to work?

Accepted Solution

  • TiggerLAS
    TiggerLAS Posts: 58  Ally Member
    Accepted Answer

    With this type of setup, don't mess with your PVID settings.

    **************************************************
    Keep VLAN1 as Untagged, and PVID1
    for all of your ports on your Zywall, GS1920,
    and your Access Point.
    **************************************************

    What this will do is essentially cause (most) anything
    plugged into those ports to wind up on your 192.168.1.x
    (VLAN1) subnet by default.

    So, if you plug in a laptop, it will wind up getting
    a 192.168.1.x IP address, and won't be able to
    reach 192.168.5.x (without specific routing
    being set up in your Zywall, anyway.)

    Conversely, If you make a port PVID5, then anything
    plugged into it will wind up on your VLAN5 instead,
    and won't be able to communicate with 192.168.1.x.



    So, I recommend FIRST going back through your
    devices, and making sure that ALL of your ports
    are set up for VLAN1, Untagged, PVID1


    Then, you'll want to assign VLAN5, TAGGED
    on your GS1920 ports 1 and 10, as well as on
    your WAX650S, and whatever port you are using
    on your Zywall device.

    Don't attempt to change PVID for your VLAN5 Ports.



    To set up your GS1920 correctly, go into the menu, and click on -

    Configuration > VLAN > VLAN

    (If you don't already have VLAN5 set up here,
    click on the Add button, and add VLAN5.)


    Then click on the "VLAN Port" link
    at the top right-hand side of that window.

    Select "VLAN 5" from the drop-down box.
    Then change whichever port(s) you are
    using VLAN5 with to "Tagged".

    (The picture below is from an 8-port switch; in your case,
    you'll be changing Port 1 and Port 10 to "Tagged".)





    Then save your settings on the GS1920.






    (You can do that later if you like, but if you forget,
    and power-cycle the switch, it will lose your settings.)




    Then, on your ACCESS POINT, check your settings,
    to make sure that you have VLAN5 defined.





    Try the suggestions above. . .   if you still can't get it working,
    let me know, and I can walk you through some trouble-shooting steps.