GS1900-48HP Voice VLAN stopped working after firmware upgrade. . .

13»

All Replies

  • YiHsien
    YiHsien Posts: 16  Freshman Member
    Thank you.
    We have set the DNS directly on the devices (PC, phone system controller) and we can access the internet successfully now. Thank you.
  • TiggerLAS
    TiggerLAS Posts: 58  Ally Member
    Hmmm.   "Set DNS directly". .  .  on the PC's?

    I was under the impression that the PC's were on VLAN1,
    and were already working correctly.


  • YiHsien
    YiHsien Posts: 16  Freshman Member
    Yes, the PCs are in VLAN1.  We were just testing if PC can access the internet in VLAN2.
    We have now successfully put the phone controller and phones in VLAN2 but our voice quality issues still exist. 
    I am wondering if you have any advises?   

    We were told that we can try to separate VLAN1 and VLAN2 in two different physical switches.   Will it help?

  • TiggerLAS
    TiggerLAS Posts: 58  Ally Member
    Some preliminary questions -

    1.)  Is the voice quality bad all of the time,
          or does it get worse with network activity?

    2.)  The NEC phone system - where are your
           incoming phone lines coming from?
           Do you have "real" phone lines, or
           something brought in digitally?

    3.)   What if you call another extension in your office;
           is the quality bad on inter-office calls, or is it just on
           calls to/from the outside world that are bad?

           (If calls between extensions in your office are fine,
            then it's probably not an in-house network issue.)

    I can't imagine that your in-house network traffic
    is enough to produce poor quality calls, especially now
    that the phones and the controller are on their own VLAN,
    and aren't being handled by your router.

    In theory, now that your phone controller, and your phones
    are on VLAN1, you could move them to a separate switch.
    You'd still need something to act as a gateway for your phones.

    Any old router, set for 192.168.2.1 could be used for temporary testing.

    I feel that there is something else going on here though.

    What are the model numbers of your phone controller,
    and your phones?   I'd like to take a peek at documentation on them.





  • YiHsien
    YiHsien Posts: 16  Freshman Member
    edited February 25
    Hi~
    1. The voice quality is not bad all the time.  It could be ok at the beginning of a call but get worse during the call.   Normally a call may only last a few minutes, and I cannot see any network activities that could affect the voice quality.

    2. Our calls are mostly from outside.  The incoming phone lines are 'real' telephone lines.  We also have traditional phones with telephone lines under the same phone controller and its voice quality is good.   So we think it is a in-house network issue.

    3.We are using a NEC SL2100 phone system.  https://www.nec.com/en/global/solutions/univerge/smb/SL2100/sl2100dp.html
       The mode number of the IP phone is IP7WW-8IPLD-C1.

    4.We have tried to use an old 8 port unmanaged PoE switch under the same Fortigate firewall.  We put the whole phone system in this PoE switch but failed. The IP phone cannot connect to the controller.   Maybe it is due to that we don't have any setting of VLAN in the old unmanaged PoE switch? (For testing, we connect a PC in VLAN1/192.168.0.x to this old switch and internet access is ok. But if we let the PC in VLAN2/192.168.2.x in the same old switch then the internet is not ok.)

    5. We have also tried to adjust the jitter buffer settings in the phone controller but in vain.

    6. We didn't use the independent QoS setting (Configuration-->QoS) in GS1900 before.   And we just set the QoS Value of our IP phones' port to 6 and we will see if there were any improvement on voice quality.

    I feel maybe the problem is from our Fortigate Firewall but not sure what can we do now.

    Here are our current network topology:

    What we want to test is:

  • TiggerLAS
    TiggerLAS Posts: 58  Ally Member

    On our switch at work, we have the Voice/VLAN/QOS settings as follows -





    And. . .










  • TiggerLAS
    TiggerLAS Posts: 58  Ally Member
    edited February 26
    I meant to ask you about something you mentioned early on. . .
    Where did you read that it was better to have static IP addresses on the phones,
    versus using DHCP to assign the IP addresses to the phones?

    Also. . .  which codec are you using?    729a ?


  • YiHsien
    YiHsien Posts: 16  Freshman Member
    Our settings are the same as your screen shots.
    As for the static IP addresses,  we have static IP addresses on the phones just simply because it is simple.
    (We don't have to deal with the DHCP settings on the firewall.)

  • YiHsien
    YiHsien Posts: 16  Freshman Member
    I found something strange.
    I use wireshark to monitor the packets.
    And I found one of our server (192.168.0.22) keeps doing ARP broadcast. (10~20 times per second)
    Is it normal? 

  • TiggerLAS
    TiggerLAS Posts: 58  Ally Member

    Do you have actual equipment at the addresses listed above?

    If it were just a few addresses, I'd suspect some sort of
    left-overs from networked printers or file shares.

    These seem to be incremental ARP broadcasts though.

    My first thought would some sort of port-scanning malware,
    so you could probably start there with a malware scan.

    Second thought - some software that you have that is
    attempting to enumerate the machines on your network,
    like some sort of backup software, antivirus, or perhaps
    a network monitoring tool.

    I would keep WireShark running on a machine
    so that you can watch it, while you log on to the server
    and start terminating tasks and/or services,
    until the ARP broadcasts stop.

    ------------------------------------------------------

    Jumping back to the phones. . .

    On the phone controller, visit the VLAN section,
    and make sure it is set for VLAN2, Priority 6.

    Then, visit IP7WW-8IPLD-C1 phones, and see if
    there is a similar Priority setting inside the phones,
    and set them to Priority 6 as well.

    If there is not a manual priority setting inside
    the IP7WW-8IPLD-C1 phones, then you may be
    forced to use DHCP for them.


Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!

Community News