USG110 firmware 4.65 performance

twixel
twixel Posts: 5
edited July 2021 in Security
I have firmware 4.25(AAAA.1) in firmware slot 1 and 4.65(AAAA.0) in firmware slot 2 in USG110. The firmware in slot 2 was upgraded based on the startup.config.conf file running in slot 1. I have switched back and forth between the two firmwares several times. When running v4.25 I have consistent upload speeds above 400Mbs. When switching to 4.65 the upload speed falls to around 100Mbs. I hope someone here have ideas to help solve this or even point me to a setting that I can change to get the performance back in v4.65.
«1

All Replies

  • mMontana
    mMontana Posts: 461  Master Member
    With no indication about your current settings?
    How these can be reviewed if the people of the community cannot know anything but firmware version and your hardware?
    :)
  • Zyxel_Jerry
    Zyxel_Jerry Posts: 547  Zyxel Employee

    Hi @twixel,

    You can check Monitor > System Status > Traffic Statistic if it is enabled.

    Enabled collect statistic may have interference on the throughput.

    You can also check if there is any UTM service running when doing the test

    May I know how do you do to test the throughput?

  • twixel
    twixel Posts: 5
    Thanks Jerry for the reply and suggestion. I use these Danish speed test websites to test the throughput from a wired workstation.

    https://tjekbredbaand.dk/hastighedstest

    I tried to disable traffic statistic but it did not have a significant impact. I also tried disabling other non essential settings to no avail. The upload speed remains much lower when running 4.65 with identical settings. Do you have other ideas?
  • mrwee
    mrwee Posts: 37  Freshman Member
    I just ran a couple of tests using https://www.speedtest.net/, and see little difference from V4.64(AAPH.0) to V4.65(AAPH.0). I'm maxxing out my USG110 at around 500-800Mbit down / 500Mbit up (Varies from test to test). No UTM service is active.



  • twixel
    twixel Posts: 5
    Hi mrwee,
    Thanks for testing that. I was wondering why your firmware is using AAPH in the version number and realized that our unit is not a USG model but just a Zywall 110. Not sure if that makes a difference when comparing the two and UTM is switched off. I tested with speedtest.net and got these results. First result is using V4.25 



    this is using V4.65



    The performance loss is so significant that I keep it running V4.25. But still hoping there is a solution.
  • twixel
    twixel Posts: 5
    V4.25

    V4.65

  • PeterUK
    PeterUK Posts: 1,154  Guru Member

    What if you save the config on V4.25 then apply it on V4.65

    If you go to diagnostics > CPU/ Memory status as your doing the upload test click refresh to see what the CPU is doing.


  • Zyxel_Jerry
    Zyxel_Jerry Posts: 547  Zyxel Employee
    edited July 2021

    Hi @twixel,

    The throughput between versions should not have a big difference, and from the screenshots of the speedtest result, it looks like only the upload speed has interference.

    You can check the CPU usage by using the below command on V4.65

    Router# show cpu average

    Router# show cpu status

    Router# show cpu all

    Could you screenshot the result of the command and share your configuration and private message to us?

    Have you ever tried the default settings(system-default.conf )on V4.65 and test the throughput and is the result the same?

     


  • twixel
    twixel Posts: 5
    Hi Peter. Thanks for the suggestion. I downloaded the running 4.25 config and applied it to 4.65 firmware. It had no impact on the upload performance problem.

    Hi Jerry. I have collected some screenshots of the show cpu command while speed testing V4.65. Generally it uses a lot of cpu during the download phase and much less during the upload phase. I will private message you the configuration file. I have not tried the default setting config file - I am worried about that one.

    download


    upload


    upload almost done

Security Highlight