QoS / BWM - Setup questions

[Deleted User]
[Deleted User] Posts: 0  Ally Member
I will probably make a support request since I am not figuring this out, but I'll give the community a shot to explain.

This is a small guide for how I configured it on my previous Ubiquiti EdgeMax 6P device, which was super simple and a breeze to do.



(from approximately timestamp 9:20 to 10:00 and forward.. My ISP delivers 100Mbit/100Mbit. )

Reviewed that a couple of times, basically two settings - done - works.

So why are there so many settings in USG40 and why is it so hard to setup?


I reviewed other tutorials as well, like
but the amount of Zyxel tutorials seem very low in comparison with others and that one is actually for VoIP...





«1

All Replies

  • PeterUK
    PeterUK Posts: 1,389  Guru Member
    edited November 2021

    Well the Ubiquiti does have a advanced queue which to me is harder to understand but yes the smart queue is simple to setup but is software loaded and can limit the max speed you get out of it.

    Zyxel tutorial miss out a important bit of setting the total Egress bandwidth in network>interface for WAN and LAN interfaces I find that -10Mb of your download and -0.9Mb of your upload speed works best then with BWM enabled you are QoS no need to add rules unless you want too priority stuff .

    You should also run the web console to enable this:

    configure terminal

    bwm control-tcp-ack


  • [Deleted User]
    [Deleted User] Posts: 0  Ally Member
    Should I not set my available bandwidth minus aprox 10% somewhere in that?
    I agree on not wanting to set any rule if I don't need it, but there must be a correct way to do this without guessing and experimenting...?
  • PeterUK
    PeterUK Posts: 1,389  Guru Member
    edited November 2021

    Their will be a little bit of experimenting but as a rule (well my rule) its -10Mb off any download speed and -0.9Mb off any upload speed so put in LAN interface settings Egress 92160Kb and WAN 101440Kb

    Do a test

    http://www.dslreports.com/speedtest


  • [Deleted User]
    [Deleted User] Posts: 0  Ally Member
    edited November 2021
    Untouched so far.


  • PeterUK
    PeterUK Posts: 1,389  Guru Member

    I should point out if you don't get you 100Mb upload all the time setting 101440Kb for WAN will not QoS your upstream and you are then subject to the QoS your ISP does which looks to be nothing so you bufferbloat same applies to download.


  • [Deleted User]
    [Deleted User] Posts: 0  Ally Member
    I should perhaps have mentioned that I hardly ever use cli so the cli cmd you posted before should probably be used in a context. Can you explain how that is done in the interface?

    I enable BWM > Saved, there is a configuration object stating something about priority
    "inbound 7 outbound 7".

    Do I add another Policy object to that? What should it contain?


  • PeterUK
    PeterUK Posts: 1,389  Guru Member
    edited November 2021

    No you don't need to add any other policy as long as you set in network>interface for WAN and LAN interfaces the Egress limits under your bandwidth speed it will work with BWM enabled.

    For the web console this is a extra settings I recommend   



  • [Deleted User]
    [Deleted User] Posts: 0  Ally Member
    Ah, "write", that was the missing thingie...
  • [Deleted User]
    [Deleted User] Posts: 0  Ally Member
    edited November 2021
    ok, found this and it helped find the egress entries.


    LAN interface settings Egress 92160Kb and WAN 101440Kb as recommended. Did not confuse them with "ingress" so I hope you didn't either Peter... :)

    I can understand those who might nerd out on these settings, I am just not one of them...






  • PeterUK
    PeterUK Posts: 1,389  Guru Member
    edited November 2021

    Your speed is unstable by your ISP so the limits you put in will not QoS

    run a ping -t to your ISP DNS or gateway IP and do a speed test to see if you get any dropped packets.

    Try a lower speed for up and down of 71680Kb to get bufferbloat “A”


Security Highlight