Unable to upgrade Firmware on GS1900-8 and GS1900-16 ZyXEL Switches

B1ggJoe Posts: 10
First Comment Friend Collector
 Freshman Member
edited August 2022 in Switch
Hey Everyone,

I've just spent the last several hours trying to upgrade the Firmware on my GS1900-8 and my GS1900-16 port ZyXEL Switches.

I've tried doing it from the Web UI for each Switch and from the ZON Utility, and nothing is working for me.

- Yes, it's the correct Firmware for each device

Any suggestions?



  • newBie_
    newBie_ Posts: 9
    First Comment Friend Collector Third Anniversary
     Freshman Member
    edited July 2018
    Hi @B1ggJoe,

    I saw your post so I've made an upgrade on my GS1900-8HP using firmware version 2.40(AAHI.1)C0.
    1. Web UI - ok.
    2. ZON utility - ok.

    My procedure is simple:
    Web UI:
    1. Access GS1900-8HP via Web UI > Maintenance > Firmware.
    2. I choose the method "HTTP".
    3. Image choose "Active".
    4. Click "Browse" choose the path where you save the file (firmware).
    5. Upload file "GS1900-8HP-2.40(AAHI.1)C0.bix".
    6. It will run for a while, then there will be a pop-out asking if do you want to reboot the device so the process will be done. (If there is no pop-out, you might want to check if the browser blocked it)
    7. After the reboot, the firmware upgrade was completed.

    ZON utility (v2.1.0):
    1. Choose my GS1900-8HP in the list box.
    2. Click on "Firmware upgrade" at the 7th icon from left to right.
    3. I've used "Online upgrade" to be convenient.
    4. Click on the GS1900-8HP in the list box.
    5. Enter the password then click "Ok"
    6. It will run for a while. then the device will self-reboot.
    7. After the reboot, the firmware upgrade was completed.

    Hope it helps
    Peace~ B)
  • B1ggJoe
    B1ggJoe Posts: 10
    First Comment Friend Collector
     Freshman Member
    edited July 2018

    Thank you very much. Yeah, for some reason...when I try to do the update from the WebUI, I get a 'Connection Reset' error message. Even though the AdBlocker is turned off.

    When I do it from ZON, it will say 'Updating'...then one of two things can happen:

    Either it will say 'Failed to update Firmware' or something like that. Or the 'Updating' message will just go away with no other message. Then when I reboot and check, it's still at the same old Firmware version.

    By the way, this is happening on both my GS1900-8 and GS1900-16. They are not the 'HP' version unfortunately.

    Very weird.

  • B1ggJoe
    B1ggJoe Posts: 10
    First Comment Friend Collector
     Freshman Member
    ** Update:

    So I was FINALLY able to upgrade both of my Switches. Long story short...I guess they're just a touch sensitive when it comes to that stuff. The GS1900-16 had a Firmware version from 11/2017 so that one was easier.

    I just had to do a fresh reboot and once it was up and running, one of my browsers was actually able to work with the WebUI upgrade.

    The GS1900-8 had a Firmware version from 2016, so that one was much harder. However, after a few clean reboots and trying to upgrade it a few times, it finally worked.

  • JonasTan
    JonasTan Posts: 65
    5 Answers First Comment Friend Collector Fifth Anniversary
     Zyxel Employee

    Based on the description, please help to check your OS firewall settings if the TFTP/HTTP/HTTPs (iSCSI service) has been blocked.

    For a quick test, you may try to disable the firewall of your OS first, then upgrade again.
    If the issue resolved, you may add this service in your firewall whitelist settings.


  • D_Shadow
    D_Shadow Posts: 18
    First Answer First Comment Friend Collector Fourth Anniversary
     Freshman Member
    Hi Guys,

    I had this problem in the beginning also.
    I've tried to upgrade my GS1900-16 via web UI and I've got this error message below.

    And after I've disabled the firewall settings on my operating system then I'd successfully upgrade my GS1900-16 to the latest version. COOL!
    But for the ZON utility, I don't have much time to make a test.

    Thanks for the advice.
  • magt
    magt Posts: 10
    First Comment
    where can I download the 2.40(AAHI.1)C0 firmware I can't update my 1900-8

  • Zyxel_Melen
    Zyxel_Melen Posts: 902
    Zyxel Certified Network Administrator - Switch Zyxel Certified Network Administrator - Nebula Zyxel Certified Sales Associate 50 Answers
     Zyxel Employee

    Hi @magt,

    Since the 2.40(AAHI.1)C0 is old firmware, we recommend you upgrade to the latest firmware.

    You could find the firmware via this link.