Problem with AP NWA5123-AC-HD

Albymatta
Albymatta Posts: 10
Friend Collector First Anniversary
edited August 2022 in WirelessLAN
Hey there, i have a problem with two AP NWA5123-AC-HD. I have a Controller NCX2500 and i connect this two new AP. The version of NCX is 6.10 AAIG2.
The VLan's are well connected, and after a few time i can see from controller that the AP had keep the right IP from DHCP, but seems to be, also after 3 hours ion Upgrading Firmare and Offline. I can see on the AP that both blinking Green/Yellow for 2 minutes, and after 5 red blink. After that the situation restart at infinite. What should i do?

All Replies

  • Zyxel_Richard
    Zyxel_Richard Posts: 191
    Zyxel Certified Network Engineer Level 2 - WLAN Zyxel Certified Network Engineer Level 2 - Switch Zyxel Certified Network Engineer Level 2 - Nebula Zyxel Certified Network Engineer Level 2 - Security
     Zyxel Employee
    edited March 2022
    Hi Albymatta,

    I'd recommend to follow the steps below with the problem.

    1. In the "AP Policy" tab, select the firmware update mode to "FTP + Manual"
    (If the traffic path from NXC to AP will pass through a firewall, please also allow the FTP service between their IPs)



    2. Remove the WAC5123AC-HD from the manage list

    3. Reboot the AP and let it managed by NXC again, checking if the IP address is displayed correctly

    4. In the AP List page, Click the "upgrade now" button (yellow lightening icon) 

    If the AP still fail the upgrade firmware, please let me know, we can go through further troubleshooting process through private message.

    Best Regards,
    Richard





  • Albymatta
    Albymatta Posts: 10
    Friend Collector First Anniversary
    Hi Richard thanks for you reply.
    I have done the step mentioned, but the AP still not done the boot correctly.. Green/Yellow light and after 5-6 red light. After that the AP reboot again. 
  • Zyxel_Richard
    Zyxel_Richard Posts: 191
    Zyxel Certified Network Engineer Level 2 - WLAN Zyxel Certified Network Engineer Level 2 - Switch Zyxel Certified Network Engineer Level 2 - Nebula Zyxel Certified Network Engineer Level 2 - Security
     Zyxel Employee
    Hi customer,

    If the device is still in the boot-up loop even after reboot, then it is regarded to the device issue. Please proceed the RMA process to return the device.

    Sorry for causing your inconvenience.

    Best Regards,
    Richard
  • Albymatta
    Albymatta Posts: 10
    Friend Collector First Anniversary
    Hi @Zyxel_Richard, thanks for your reply

    I would post this for helping other user in that trouble, because i have resolve that.
    I have seen that with the controller sometimes the settings that you have post before can be "default" (CAPWAP such provisioning method and automatic firmware update), but sometimes can happened that this settings can cause firmware conflict like my situation.

    So, i have seen that the problem was the firmware conflict generated. Premise that, like a lot of other network devices, the Access Point have 2 boot image. My controller put in boot-image1 the versione 6.10, while the AP comes with factory firmware 6.20. So, the AP maybe doesn't recognized the firmware.

    For the resolution, i bought one cable USB-TTL (for the console link) and entered in Debug Mode.
    After that i have update the firmware with the 6.25 and now the AP boot with the correctly image (i must set a TFTP server on a machine)

    I have only one question: now i have the firmware image 6.25 on boot image 0 and 6.10 on boot image 1. In other network devices is possibile copy the boot image, but i cannot found a command for this. I want copy the boot image 0 in the boot image 1, because, if the AP start with the boot image 1 fail the startup.

    Thanks. 
  • Zyxel_Richard
    Zyxel_Richard Posts: 191
    Zyxel Certified Network Engineer Level 2 - WLAN Zyxel Certified Network Engineer Level 2 - Switch Zyxel Certified Network Engineer Level 2 - Nebula Zyxel Certified Network Engineer Level 2 - Security
     Zyxel Employee
    Hi @albymatta

    Glad to hear your issue is solved by yourself through the console cable.
    Let me explain the behavior of two firmware images:

    Two images are categorized into two usage > running image and standby image.
    In your case, image1 is running image(6.25), and image 0 is a standby image(6.10).

    How it works is, when AP upgrades firmware, it will first put the firmware in the standby image, and then swap the running image and standby image.

    For example, if you upgrade your AP in the future (6.26 for example), this new firmware will be applied to image0, and then AP will use image0 as running image, while keeping the image 1 as v6.25, but as a standby partition.

    Please noted that, both images share the same configuration, so the "image" on our AP is just a storage for the firmware file, not the configuration/settings of the AP, so you don't need to copy the firmware image.

    Best Regards,
    Richard

  • shortl
    shortl Posts: 9
    First Comment Friend Collector Second Anniversary

    hy albymatta, i've the same problem with mine 5123-ac-hd, boot loop, do you have a pin-layout for the console debug port? cause i've a usb-ttl at home….

    thx

  • Zyxel_Judy
    Zyxel_Judy Posts: 544
    Zyxel Certified Network Engineer Level 1 - Security Zyxel Certified Network Administrator - Security 50 Answers First Comment
     Zyxel Employee

    Hi @shortl ,

    Please refer to this thread to know about the Zyxel console port.

    Hope it helps!

    Regards,

    Judy