Recovery Steps for USG FLEX/ATP Series Application Patrol Signature Issue



  • CoreSG
    CoreSG Posts: 40  Freshman Member
    I have a device still on V5.00(ABUJ.2)
    but the update notes recommend upgrading to "ZLD5.10 C0 or later version first before upgrading to ZLD5.20"

    Is your documented procedure even *SAFE* for ANY unit more than one version behind ?
  • Zyxel_Vic
    Zyxel_Vic Posts: 264  Zyxel Employee
    Hi @CoreSG
    Thank you for the feedback but are you trying to upgrade to 5.20?
    If so, please upgrade to 5.21p1 directly but not going through any versions in between. 

  • Trilogy
    Trilogy Posts: 4
    For me, the recovery process described here worked, thank god.

    Step 9 was not necessary. My ATP 500 connected to Nebula again and downloaded the full config without having to manually remove and add it again. I will now not touch my installation until 13:00 UTC and hope for the best.
  • Trilogy
    Trilogy Posts: 4
    I am aware that I used tough words yesterday, and I want to thank everyone at Zyxel Support and Engineering who is working to solve this issue.

    But after you fixed it, please do review how this happened and make sure we do not end up in such a situation again. It really is a no-go. I was fortunate, not everybody will have had the means to organise a serial cable and software ASAP, as this method of access is not really standard anymore these days. And perhaps, in the age of easy-to-use Nebula & Co. not everyone will have the required skills anymore, either. 

    So, please make sure there is a very good review and lessons learned from this incident. And thank you for otherwise very great products.
  • Pook
    Pook Posts: 88  Ally Member
    Hi everyone, could you confirm whether today's forced update will cause any of the Firewalls to reboot automatically? Just we have quite a few in live / working environments using VPN's....
    All the best - Adam
  • Zyxel_Tobias
    Zyxel_Tobias Posts: 194  Zyxel Employee
    Hi Pook,

    for On-Premise / Standalone = NO
    for Nebula Cloud = Yes, 5 Minute downtime around 2PM GMT +1
  • Pook
    Pook Posts: 88  Ally Member
    Would of been good to do this OOH's surely ... but it is what it is - thanks for letting me know :-(
  • maol
    maol Posts: 1
    After update to ZL5.21 no access to internet possible?
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,136  Zyxel Employee
    Hi @maol
    Does your device is to boot up successfully?
    You can drop private message to me if you need further help. :)
  • bymusty
    bymusty Posts: 13  Freshman Member
    @Zyxel_Stanley and @Zyxel_Emily
    If the newly released signature is updated on devices that are affected by the signature and not rebooted, will the device be fixed? Or, if the devices before the 5.21p1 firmware (for example 5.02 - 5.10-5.20 firmware) that did not receive the signature dated March 10 before and were not affected by the problem, update the signature dated March 16, is it a problem that the device is rebooted?