GS1900-8HP Login

bilbo Posts: 8
edited April 2021 in Switch

I am able to login to the GS1900-8HP using Windows 10 and setting a static address I changed these settings: admin password, SNMP Global State to disable, SNMP Group string from "public" to "nonpublic."  This eliminated the warning at the start of the GUI for Admin Password and SNMP Public settings.

PROBLEM: I cannot access the switch from Linux when the switch is in a reset state, or after power loss. After reset / power loss the switch defaults to a static addressing and I can access the switch from Windows 10 using, but I cannot access it using Linux. Either, I am not setting up Linux Static Addressing correctly or the Linux GUI for Static Addressing is buggy. I have not used Linux command line networking.

When I set the switch to dynamic addressing I am able to access the switch login and login appropriately with Linux.

I DO NOT want to rely on Windows 10 to access this switch after power off.

Accepted Solution

All Replies

  • Sakura_T
    Sakura_T Posts: 101  Ally Member

    What is the static IP of your host when using Linux?

    It's seemingly you didn't set an IP within the same subnet 192.168.1.X, hence no communication.

  • bilbo
    bilbo Posts: 8

    I updated the Firmware to V2.40(AAHI.1) 03/30/2018

  • bilbo
    bilbo Posts: 8

    I don't think I've ever gotten to a static IP on the Linux Host, that is my problem. I need some help from someone who knows the Linux GUI. Using Ubuntu 18.04: Settings>Network>Wired>IPv4 TAB>IPv4 Method has four radio buttons: Automatic, Manual, Link-Local Only, Disable. Choosing Manual gives


    Address Netmask Gateway

    DNS Automatic ON or OFF ?

    Routes Automatic On or OFF?

    Checkbox: Use this connection only for resources on it's network Checked or Unchecked?

  • bilbo
    bilbo Posts: 8

    I'm following the same approach as shown through a Windows 10 box. The Host IP address is NOT the same as the Network card IP address?

    I guess I'm completely lost. IF I want to change the Host to 192.168.1.x I CANNOT do that by changing the address of the Network Card?

    I probably need some basic Networking How-to for Ubuntu. Any suggestions?

  • bilbo
    bilbo Posts: 8

    Sakura_T I'll start by looking at command line ifconfig and working from there. I've been wasting my time, and yours, with this GUI approach.

  • D_Shadow
    D_Shadow Posts: 18  Freshman Member


    It seems to me that all you need to set is simply "manual" and IP address.


  • bilbo
    bilbo Posts: 8

    D_Shadow my Network GUI window looks different, but all the basics are the same. That has NOT worked. After I resolve this issue I'll get back to you with a screen shot and a solution.

    I'm using Ubuntu 18.04. Thanks for your time.

  • bilbo
    bilbo Posts: 8

    It's obvious I'm going to need some help on this issue. This is not some Mission Critical issue, so I'm going to save my sanity, by NOT letting it get me worked up. If I have to, I'll replace the switch with a basic 4 port switch and be done with it. Thankfully I have AC in my office/studio.

    My new question is: is there anybody here who has accessed this GS1900-8HP switch from Linux after it has been reset? I'm sure there is.

    I include some edited screenshots from yesterday.

    I'm capable, but not "the expert" on networking. Any suggestions, I thank you, in advance.

    I'm going to set up a Linux box, off to the side, so I can tinker with this problem / project.

  • bilbo
    bilbo Posts: 8

    Hi Lucious

    MAC table could be the problem. I'll look into that. I have never set up the switch beyond changing the password. I'm able to add devices and computers to the switch. Such as a streaming BluRay player that works fine.