Very weird problem

FS1976
FS1976 Posts: 2
edited March 9 in Smart Home Product
Hi, people.

I have been struggling with this problem for about a week now, and I don't know what to do!

We have a VMG8823-B30B router in our home network and it works fairly well. We have a Sony Smart TV with Android with wired connection and three phones, a few laptops and an iPad using the wireless network.

Since March 1st Disney+ hasn't been working on the TV. Soon after that two other streaming service apps stopped working as well. Everything else works and the remaining streaming apps work too. The problem is just with those three.

Soon I found out that the same three apps don't work on my Huawei phone either. Same issues and behavior.

Now here come the fun parts:

1. All three streaming apps have had updates during this first week of March.

2. If I turn off my phone's wifi connection and in stead use internet by 4G all three streaming apps work fine. Thus meaning that they only won't work using our home connection.

3. My wife's iPhone has no trouble using those three apps with her iPhone/iOS through our home connection/wifi.

4. My phone and the TV both use Android.

SO - as far I have deduced: The three apps in question only won't work through our home connection (both wireless (phone/TV) and wired (TV)) and obviously from devices using Android!

My troubleshooting has been this so far:

- Clearing app caches in both my phone an TV.
- Uninstalling the three apps and installing them again.
- Restarting/shutting off the TV.
- Restarting/shutting off the phone.
- Pressing the restore button on the Zyxel router.
- Calling Disney+ and have them check if they had heard about any similar problem.
- Calling my internet provider who told me that everything was fine from their part (and everything else works fine too!)

So I feel my only option left is to dig into the router itself. It could seem to me that perhaps there is some sort of preference that could be adjusted in some way to make those three apps work?

Does anybody have any suggestion here? Please?

This is driving me NUTS!

BR
Freddy

All Replies

  • Scorpione
    Scorpione Posts: 20  Freshman Member
    I think:
    -Inside the router there is a mac adress limit or firewall that block 3 peripherals
    -Disney have a limit max of peripherals inside the account, probably you must delete 1 or more clients


  • FS1976
    FS1976 Posts: 2
    Thanks for the answer. 

    By 'client' - do you mean Disney+ apps on different devices? Because right now it's only the TV that has the app installed and it still doesn't work. The other two apps (CMore and Viaplay) do the same thing.

    And one more funny thing: If I watch Disney+ on an open browser on said TV, it works fine. A bit slow, but that's the browser.

    So the issue is with the apps, not the streaming service. 

    Since I wrote my question I've even tried changing my primary and secondary DNS on the TV.

    And I switched off the 'Private DNS' - setting on my phone. 

    Still nothing works. So strange. 
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!