USG 40W with low internet speed

Uwe67
Uwe67 Posts: 3
First Comment Second Anniversary
 Freshman Member
edited April 2021 in Security
We changed our internet provider to get faster internet speed (100 Mbit instead 6 Mbit). Our Provider is Telekom and we got this Digitalisierungsbox Smart.
Everything is working fine, but we have nochange in unternet speed. The maximum download speed is 5-6 Mbit, the upload is max. 20 Mbit. This should be 100 MBit / 40 MBit. I try a lot of configuration things in the USG and if I switch off the policy control I got a download from 95 MBit. So I think the problem is too low throughput of the USG or too low processor power?
When I look into the data sheet, it should have enough throughput, but it hasn´t. Can I do or check something to get better values ?

The licenses of the USG will expire next month, so I Think about to change the device against an other model with more power?

Thank you in advance and Best regards
Uwe
«1

Comments

  • Zyxel_Charlie
    Zyxel_Charlie Posts: 1,034
    50 Answers 500 Comments Friend Collector Fourth Anniversary
     Zyxel Employee
    @Uwe67
    I would like to know do you enable all UTM features?
    If UTM are enabled, the each packet will be checked. This may cause the slow speed.
    In the datasheet, the test was based on UDP packets but not TCP since TCP throughput may be affect by different factors due to handshake mechanism.
    To understand what may lead to low throughput result on your device, can you private message your configure to me for checking?

    Also, I would like to know what is you test method of this case.

    Charlie

  • kydimos
    kydimos Posts: 4
    First Comment Third Anniversary
    We are experiencing a low throughput on our Zywall USG 20W. We have a 170 Mbit connection but only obtain 80 Mbit thought the USG. We use latest 3.3 v. 9 firmware and have disabled ADP. When testing without the USG we get 170 Mbit. Disabling the firewall gives 100 Mbit i total. please advice.  
  • PeterUK
    PeterUK Posts: 1,444
    50 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    edited May 2019
    The Zywall USG 20W is a low end unit a USG40,60 or ZyWALL 110 should be able to handle 170Mb.
  • kydimos
    kydimos Posts: 4
    First Comment Third Anniversary

    The stated throughput is 175Mbit. There is a lot of room for improvement. And if this product under performs the whole product range might as well under perform. Or maybe it is possible to configure the product to perform as listed? Explaining it as 'low end unit' is a counterproductive simplification of the problem :) 

  • kydimos
    kydimos Posts: 4
    First Comment Third Anniversary
    BoudahXL said:
    PeterUK said:

    The USG 40 maybe listed as 400Mb but under given test conditions with TCP and without Anti-Virus, IDP, or Content filter you should get about 200Mb

    Thanks, I'm still 25-30mb/s short of that, what would be the right appliance then, do they have a model that would be able to offer 250-300mb/s with some services? Seems like I'm going to have to return this box now :(

    Apparently everybody else are having the same kind of problems with the other models you are suggesting and you still offer the same kind of answer?! 
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,180
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    edited May 2019

    Hi @kydimos

    In the datasheet of USG20 performance is around 175 Mbps, but it is tested by UDP. 

    (UDP performance will higher than TCP)

    To fulfill performance requirement, USG20-VPN can handle it. You can consider upgrade to this model.


  • kydimos
    kydimos Posts: 4
    First Comment Third Anniversary
    If an announced UDP throughput of 175 Mbps corresponds with an actual TCP throughput 80 of Mbps (45 %) then an announced throughput of 350 Mbps correspondingly should give 157 Mbps TCP and we still risk running a bit short with no with no room for upgrading the line :) Hmmm ...
  • Zyxel_Stanley
    Zyxel_Stanley Posts: 1,180
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    The performance will different in difference test conditions. (e.g. PC hardware/ packet length/ protocol / session numbers…etc)
    In datasheet it is based on RFC2544 and tested by full sessions. So performance will not the same.
  • FreedomAngel2022
    FreedomAngel2022 Posts: 3
    edited February 12
    My USG20 only reaches 0.75 MBITs while connected to a WAN Router that can theoretically reach 100 MBITs. Without USG20 in the middle I reach 11 MBITs in download speed, with USG20 activated only the 20 years outdated 0.75 MBITs. Any idea how to fix that in the settings?
  • CHS
    CHS Posts: 155
    First Answer First Comment Friend Collector Fourth Anniversary
     Master Member
    You can check if there is any content filtering or IDP function are enabled. Not sure what function is enabled on your device, you may have a test by system default configuration for check first.

Security Highlight