VLAN-to-VLAN communicatons on same switch (NSW100) and NSG100

MortenL
MortenL Posts: 2
edited June 2021 in Nebula
Hi, I am completely stuck, I really hope somebody can help me with this.

So I have a big building with three companies in who want to share their printers. And I have a NSG100 and a NSW100.

So I have set up:

VLAN1 for management, switch port 1, subnet 10.193.80.0/24
VLAN81 - for company1, switch ports on NSW2-30, subnet 10.193.81.0/24
VLAN82 - for company2, switch ports on NSW31-38, subnet 10.193.82.0/24
VLAN83 - for company3, switch ports on NSW39-42, subnet 10.193.83.0/24
VLAN142 - for printers, switch ports on NSW43-48, subnet 192.168.142.0/24 

All VLANs are configured with DHCP-servers for their IP-range.

So when I connect my computer to the different ports on the NSW, they get the corresponding IP, which is correct and they get internet-access. Great.

But when I am on VLAN81/82/83, and try to ping the printer which is on VLAN142, with IP 192.168.142.14, I get "Request timed out". I CAN ping 192.168.142.1 though, which is the router.

If I change the port of the computer to VLAN142, it CAN ping 192.168.142.14.

What I am doing wrong? I have tried to enable/disable firewall rules, as well as static routing/policy routes - but nothing works. 

I have also tried to change the ports from ACCESS to TRUNK, and allow all VLANs to enter, but that doesnt help either.

Thank you for anyone who can help!

MortenL

Accepted Solution

  • MortenL
    MortenL Posts: 2
    edited June 2021 Answer ✓
    This was all my bad. The printers were set up with the wrong gateway, which needed to be 192.168.142.1

    No policy routes or security policies are required.

    The only thing required is to insert the VLANs in the interface and tag the corresponding ports on the switch.

Nebula Tips & Tricks