Wired devices losing connection to VMG3925-B10C router after 24 hours

tfav
tfav Posts: 2
edited June 2021 in Smart Home Product
I have a problem similar to what was reported in this topic: https://community.zyxel.com/en/discussion/4064/some-devices-lose-connection-after-24h

I have a VMG3925-B10C router and lately all my wired devices are losing connection to the router periodically, usually after 24 hours. Connections can be restored by restarting the router. I tried setting lease time for IPs to 365 days, but it didn't help. My firmware version is V5.13(AAVF.14)C0. Everything was working fine when I only had a couple of computers connected to the router with ethernet cables.

I have two ZyXEL GS-105B switches connected to the router and behind them I have:
- 2 computers connected to switch 1
- 2 computers and a TV connected to switch 2

In addition to those, I have a few other devices connected through WiFi. They seem to not lose connection at all.

All Replies

  • tonygibbs16
    tonygibbs16 Posts: 433
    5 Answers First Comment Friend Collector Second Anniversary
     Master Member
    Hello @tfav

    Looking at the information in the user guide at ftp://ftp.zyxel.com/GS-105B/user_guide is the link activity light on your switch ports on or blinking when the wired computers lose connection ?

    This might help you to know if the problem is between the switch and the router, or between the switch and the wired computers.

    Kind regards,
         Tony


  • tfav
    tfav Posts: 2
    Looking at the information in the user guide at ftp://ftp.zyxel.com/GS-105B/user_guide is the link activity light on your switch ports on or blinking when the wired computers lose connection ?
    They are blinking. I also tried another switch from D-Link, and it had the same problem. Before when I had only two wired devices connected straight to the router with the same cables I now use to connect the switches to the router, this problem never happened. It feels like somehow the switches or increased amount of wired devices are causing the router to malfunction.

Consumer Product Help Center