How to set up GS1900 VLAN's using a non-Zyxel router?

UserJ
UserJ Posts: 3

I’m having trouble getting VLANs to work on my Zyxel GS1900-8.

In my test situation, the GS1900-8 has 2 ports connected:

  • On port 1, it’s connected to my Asus router with (highly configurable) Fresh tomato firmware. I have 2 VLAN’s on the router; VLAN2 and VLAN3. Those VLANS works fine together with a Zyxel NAP102 WAP that's connected to this ASUS router.
  • On port 4, my Windows10 laptop.

All works fine in the 'default' situation; if I configure the ASUS router to send untagged packages to port 1 of the Zyxel GS1900-8, because the GS1900-8 uses it’s default VLAN1 and has all ports in the ‘untagged’ section by default.  

Then I tried to set up VLANs by configuring:

  • the ASUS router to send tagged VLAN2 and VLAN3 packages to the GS1900-8
  • the GS1900-8 as follows:VLAN2 settings: port 1 (the Asus router) = ‘Tagged’, Trunk enabled, port 4 (my laptop) = untagged and Trunk disabled, all other ports=excluded.

This doesn't work; f.i. from my laptop on port 4, I can’t ping the ASUS router on port 1, when I would expect them to connect via VLAN2.

Have I misconfigured something? Or could it be possible that the packaged tagged by the ASUS router aren’t compatible with the GS1900-8? The ASUS router works fine with the Zyxel NAP102 though…

 

I would highly appreciate your thoughts, as I've spent several hours and can't solve it myself...

Regards, John




Accepted Solution

  • Zyxel_Adam
    Zyxel_Adam Posts: 105  Zyxel Employee
    edited July 21 Accepted Answer
    Hi @UserJ,

    Welcome to Zyxel Community!

    For your scenario, you need to configure PVID 2 for port 4 of GS1900 since your laptop is untagged device and connected on it, and you don't have to enable VLAN Trunk.

    Description of VLAN Trunk:


    This means that when your GS1900 enables VLAN Trunk on port 1 and without creating any VLAN (only VLAN 1) then GS1900 will pass VLAN 2 & 3 from ASUS router to other switch, for example.


    Adam

All Replies

  • UserJ
    UserJ Posts: 3
    Hi Adam,

    Thanks for your swift and helpful reply. It's working fine now!

    Regards, John
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!