I need firmware for VMG3326-D20A VDSL modem

Hi, I purchased this device and it is not working.
I believe I need to update the firmware to make it work.
Where can I download firmware for VMG3326-D20A VDSL modem?

Thanks!

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 2,002  Guru Member
    Answer ✓
    According to this wiki that modem is only sold to ISP's. So you have to ask the ISP for firmware updates. But as it is quite old, I doubt there are still updates available.
    If that wiki is right, you can try to install OpenWrt for the P-2812HNU-F1, which is identical. Unfortunately you can't install a ZyXEL firmware for the P-2812HNU-F1, as the current firmware won't accept it.

All Replies

  • MAhti
    MAhti Posts: 2
    Mijzelf said:
    According to this wiki that modem is only sold to ISP's. So you have to ask the ISP for firmware updates. But as it is quite old, I doubt there are still updates available.
    If that wiki is right, you can try to install OpenWrt for the P-2812HNU-F1, which is identical. Unfortunately you can't install a ZyXEL firmware for the P-2812HNU-F1, as the current firmware won't accept it.

    Thanks Mijzelf, this is a really good and clear answer.
    Unfortunately it seems as if I have been mislead when purchasing the modem, the seller said the modem works for any ISP, but it seems it is tied to a specific ISP.
    I believe the steps to install OpenWrt are quite difficult for a normal person, I was hoping it would have been just a firmware update, but it seems to be more complicated than that.
    I will try to roll back the sale, and look to purchase a new modem which is not ISP locked.
    Thanks once again and have a lovely continuation of the summer!

Consumer Product Help Center