Armor G5 AX6000 cannot hold LAN connection

My LAN connection will continue to drop consistently every 10-30 seconds, impossible to do any online gaming. Have recently upgraded firmware to v1.00(ABSK.7)C0. Attached a picture of what an average ping session looks like 

I have disabled wi-fi as I use an AP in my home. Only connections are PC via multi-gig port and AP via 1 gig port. No special settings, has not worked correctly since getting router setup.

Accepted Solution

  • xDooZyy
    xDooZyy Posts: 3
    Answer ✓
    Hey just to round this out. The issue was the router wasn't holding DHCP from my ISP. The ISP came and swapped out the router and it fixed it, no issues with the new router. Thanks for the help!

All Replies

  • To add on, this is what the logs look like. Unfortunately I cannot export them as apparently I don't have a password for the log .tar file when you export. 
  • Zyxel_Jerry
    Zyxel_Jerry Posts: 609  Zyxel Employee
    Hi @xDooZyy,

    Have you checked with different cables, is the issue still occur or it only happen on the same cable?
    Does using other LAN ports have the same issue?
    Does the other laptop under Armor would have the same symptom?

    You can private message the log .tar file to us by following steps below,
    Click username which you want to sent the private message.
    Click "Message",  now, you can enter your message in the blank, and click "Post Message" to send it out


  • Dexter
    Dexter Posts: 108  Ally Member
    Maybe you can try to disable Energy efficient ethernet (and or green energy) and Wake on magic packet.

    Go to Device Manager, network adapters and find the ethernet one you currently using.- right click for properties - advanced 
    Disable Energy efficient ethernet (and or green energy) and Wake on magic packet.

Consumer Product Help Center