Google Mini nest: connect with old Zyxel router, not new one (Help please!)

I am using a Zyxel Model VMG3925-B10C, Firmware V5.13(AAVF.13)J1. These are provided by John Lewis broadband (basically it's Plusnet, sold via John Lewis)

I was initially connecting using a Zyxel Model VMG3925-B10A which worked fine with all our devices, including six Google mini nests. Unfortunately the old router started losing connection every half hour. After lots of telephone diags etc, John Lewis sent a new router, the VMG3925-B10C. This stayed connected but the Google Mini Nests failed to connect, displaying a message "check password"   Obvs I did this and have connected, disconnected, reset, uninstalled, reinstalled, changed passwords etc, I estimate I've tried the above 56 or so times. John Lewis sent out an engineer who also couldn't get it to work, saying it was a router fault. A new router arrived and the same issue is occurring.

However, if I re-instate the old router (the one that drops connection), ALL devices connect perfectly within minutes. Unfortunately this old router then drops out after about 30 minutes!

Any suggestions of anything else to try would be very welcome.


All Replies

  • Killer133
    After working at fixing this for on & off two weeks, Mark at John Lewis Broadband's support group came up with this solution:-

    The issue is with the model VMG3925-B10C router's factory settings. In Wireless Settings > Other I switched off 802.11 Protection and disabled "Protected Management Frames"

    As soon as this was done the Google Smart Speakers immediately connected successfully 

Consumer Product Help Center