GS1900-10HP Wake on LAN

jeffshead
jeffshead Posts: 7
edited March 19 in Switch
Wake on LAN works on all ports except for the SFP ports. Is this normal?

I am using two of these transceivers:

«1

All Replies

  • jeffshead
    jeffshead Posts: 7
    edited March 19
    Response I got from SFP transceiver manufacturer:
    In our experience, the WOL function has nothing to do with SFP modules. Generally, after the SFP on the switch side is disconnected, the connection may not be maintained. There is indeed a possibility that WOL cannot wake up the PC.

    With the Ethernet cable plugged into one of the SFP transceivers, I get one solid light on the NIC, in the PC, when it sleeps and WOL does not work.

    On the switch, if I move the cable from the SFP transceiver to any of the regular ports, I get a solid light and the second light on the NIC, in the PC, slowly blinks and WOL works.



  • Zyxel_Melen
    Zyxel_Melen Posts: 227  Zyxel Employee
    Hi @jeffshead,

    Welcome to Zyxel community!
    This is because the link speed down to 10 M/F after PC sleep.
    But the SFP port only support 100 Mbps & 1 Gbps, the link will down after PC sleep.
    I suggest to change your network card setting "WOL & shutdown link speed" to 100 Mbps or not speed down in order to keep the link up after PC sleep.

    Here is the steps:
    1. Open Settings.
    2. Click on Network & Internet.
    3. Click on Status.
    4. Under the "Advanced network settings" section, click the Change adapter options button.
    5. Right-click the active network adapter and select the Properties option.
    6. Click the Networking tab.
    7. Click the Configure button.
    8. Click the Advanced tab.
    9. Select the WOL & shutdown link speed option.
    10. Use the "Value" drop-down menu and select the 100 Mbps first or not speed down option.
    Hope it helps.
    Melen
  • jeffshead
    jeffshead Posts: 7
    Thank you. I have Intel NIC, not Realtek. I checked for similar setting but did not find any. I updated the driver and found a new setting named, "ReduceSpeedOnPowerDown". I disabled it because that setting is the equivalent of the Realtek setting for which you previously described but that did not help.

    Is there another Intel NIC setting that needs to be changed?
  • Zyxel_Melen
    Zyxel_Melen Posts: 227  Zyxel Employee
    Hi @jeffshead,

    I found an article from DELL that the Intel 82578DM NIC has this option "Reduce link speed during system idle" in the Power Management settings: link
    Not sure if your Intel NIC has this setting or not.
    If not, I suggest you can ask Intel support or just plug you cable to the regular ports.
    Or you can check this topic in Intel community: link
    Melen
  • jeffshead
    jeffshead Posts: 7
    I have toggled off all power/speed saving settings within the NIC settings, including the one mentioned above. I have also disabled all power saving options in the operating system and BIOS. I'm still not able to get WOL working with the SFP ports.
  • mMontana
    mMontana Posts: 640  Guru Member
    Is your computer configurated (via BIOS) to be waked up from PCI-Express card?
  • jeffshead
    jeffshead Posts: 7
    Yes, BIOS is set to allow WOL for LAN/WLAN. There's no WOL setting for PCI-Express in the BIOS.
  • mMontana
    mMontana Posts: 640  Guru Member
    edited April 30
    jeffshead said:
    Yes, BIOS is set to allow WOL for LAN/WLAN.

    But an external card to the motherboard could be not recognized as LAN from your BIOS/UEFI
    jeffshead said:
    There's no WOL setting for PCI-Express in the BIOS.

    But there could be some settings into power management for allowing PCIe to wake/power on the computer. Unfortunately without knowing your device it's quite hard to point you to some hints.

    This doesn't mean that WOL is working as expected from the switch.

    Unless your PC/mainboard has an integrate SFP slot...
  • jeffshead
    jeffshead Posts: 7
    I never mentioned having an add-on card :-)

    I have tested with three different PC's. All with onboard Intel NICs. None of the PC's can WOL when connected to the SFP ports but they all wake when connected to the regular ports on the switch.

    PC's tested are Dell Optiplex:
    • 9010 SFF (82579LM)
    • 7050 MFF (I219-V)
    • 7070 MFF (I219-LM)


  • Zyxel_Melen
    Zyxel_Melen Posts: 227  Zyxel Employee
    Hi @jeffshead,

    Just like I mention in the first response, this is because the link speed of PC will change to 10 M/F after PC sleep. But this speed duplex is not support on SFP port.
    If you need to connect your PC to switch's SFP ports and have WOL function, you might need to find a NIC card which support to change the "WOL & Shutdown Link Speed" to 100 M/F or can disable "Reduce link speed during system idle".
    Melen