USG310 - L2TP VPN - GUI Error? - Unable to select VPN Connection

I have a fully working IPSec and L2TP VPN on the firewall. Tested and used for 2yrs+.

Just upgraded to v4.72 (latest) firmware. Model is USG310.

GUI Page = VPN > L2TP VPN

Issue:
The drop-down for "VPN Connection" now contains "Please select on..." and the only option is "none".

Expected Behaviour:
The configured IPSec VPN should be selectable (was previously).

Notes:
Not sure if the requirements have changed or if this is a fault in the GUI.


Best Answers

  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 1,450  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Hi @AaronReynoldsUK,

    Welcome to Zyxel community.  B)
    This is not expected behavior. Can you send me startup configuration file in PM for further checking?
    Thanks.
  • AaronReynoldsUK
    AaronReynoldsUK Posts: 4
    Friend Collector
    Answer ✓
    Hi @AaronReynoldsUK,

    Welcome to Zyxel community.  B)
    This is not expected behavior. Can you send me startup configuration file in PM for further checking?
    Thanks.

    Zyxel_Cooldia identified that I was incorrectly using "mode config" on the IPSec configuration (incompatible with/overriding L2TP on ZyXEL), once disabled the VPN Connection was again selectable in L2TP configuration.

All Replies

  • PeterUK
    PeterUK Posts: 2,705  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    Re check vpn connection and VPN gateway settings for L2TP VPN


  • mMontana
    mMontana Posts: 1,300  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Later versions (4.x) sometimes to not have any L2TP gateway/connection configured.
    You can re-enable them with a specific terminal command documented into a KB.
  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 1,450  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Hi @AaronReynoldsUK,

    Welcome to Zyxel community.  B)
    This is not expected behavior. Can you send me startup configuration file in PM for further checking?
    Thanks.
  • mMontana said:
    Later versions (4.x) sometimes to not have any L2TP gateway/connection configured.
    You can re-enable them with a specific terminal command documented into a KB.
    I'm not sure this applies, but if you can send a link to the KB, I can check it.
  • Hi @AaronReynoldsUK,

    Welcome to Zyxel community.  B)
    This is not expected behavior. Can you send me startup configuration file in PM for further checking?
    Thanks.

    Thank you.

    I've PM'd you a redacted startup config.
  • AaronReynoldsUK
    AaronReynoldsUK Posts: 4
    Friend Collector
    Answer ✓
    Hi @AaronReynoldsUK,

    Welcome to Zyxel community.  B)
    This is not expected behavior. Can you send me startup configuration file in PM for further checking?
    Thanks.

    Zyxel_Cooldia identified that I was incorrectly using "mode config" on the IPSec configuration (incompatible with/overriding L2TP on ZyXEL), once disabled the VPN Connection was again selectable in L2TP configuration.
  • Is there any solution for this error or should we just throw Zywalls away?
  • zyxel support ridiculous
  • Zyxel_Cooldia
    Zyxel_Cooldia Posts: 1,450  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Hi @hgmrtn,

    Welcome to Zyxel community.  =)
    Please help to check if mode config is tick in VPN phase 2. 
    Go to IPSec VPN > VPN Connection > RemoteAccess_L2TP_Wiz > Mode Config.
    Turn off "Enable Mode Config". Mode Config is for software IPSec VPN client (the green bow client).
    Then you can find it appears on the drop-down list of L2TP > VPN Connection. On this page, IP Address Pool assigns IP addresses to L2TP VPN clients, so you don't need to configure Mode Config in VPN Connection > RemoteAccess_L2TP_Wiz.

Security Highlight