NAS542 very slow and unstable file transfer

Hi my NAS542 has become very slow during file transfer (usually 5 mb/s) and sometimes the file transfer stop with a error.

I tried to transfer files with terminal but it doesn't solve the problem

My FW version is V5.21(ABAG.7)

I tried to reset and initialize the nas, change to RAID5 to JBOD, change Hard Drives, nothing solve the problem

Is it a hardware problem?

All Replies

  • Mijzelf
    Mijzelf Posts: 2,001  Guru Member
    If it is a hardware problem of the NAS, you should see error messages in the kernel log (which can be read by executing dmesg in a telnet/ssh shell)

    You are not using wifi, are you?
  • CarmineB84
    CarmineB84 Posts: 3
    Mijzelf said:
    If it is a hardware problem of the NAS, you should see error messages in the kernel log (which can be read by executing dmesg in a telnet/ssh shell)

    You are not using wifi, are you?
    In the log aren't error message and no, I'm on gigabit ethernet cable.
  • ikubuf
    ikubuf Posts: 45  Freshman Member
    edited June 15
    You can set up a static IP on the NAS and set up the same subnet static IP address on your laptop.
    e.g : NAS IP :  192.168.20.20   NAS gateway IP : 192.168.20.50, LAPTOP IP: 192.168.20.50
    Connected both with ethernet cable directly, and check the upload and download speed.

  • ariek
    ariek Posts: 25  Freshman Member
    Mijzelf said:
    If it is a hardware problem of the NAS, you should see error messages in the kernel log (which can be read by executing dmesg in a telnet/ssh shell)

    You are not using wifi, are you?
    In the log aren't error message and no, I'm on gigabit ethernet cable.

    If you log
  • ariek
    ariek Posts: 25  Freshman Member
    edited June 15
    When you log into the router, does it indicate that the connected NAS is actually connected at 1000 Mb/s and not 100 Mb/s?
    A potential auto negotiation problem. On my NAS520 this problem occurs during the daylight saving time transition.


    Are you using link aggregation/port trunking? If so remove it so that the NAS can be accessed over two network ports and check that both ports have a speed of 1000 Mb/s (check the connection speed in the router).
    When both ports show a speed of 1000 Mb/s you can enable port trunking/link aggregation again.


  • CarmineB84
    CarmineB84 Posts: 3
    ikubuf said:
    You can set up a static IP on the NAS and set up the same subnet static IP address on your laptop.
    e.g : NAS IP :  192.168.20.20   NAS gateway IP : 192.168.20.50, LAPTOP IP: 192.168.20.50
    Connected both with ethernet cable directly, and check the upload and download speed.

    the trasfer is stable and fast, maybe is a problem on ethernet line, switch or router

Consumer Product Help Center