AP not handing out DHCP IP addresses to clients - why?

Aisman Posts: 2
Hi Everbody, 

I needed a quick wifi setup, and bought 4 Zyxel NWA50AX, then connected to a POE Switch and created a Nebula profile. 
All seems good: I see the AP in Nebula, they are online and get an IP (both internal and "public", also if I don't know what the latter is for) but... 
I have 1 SSID with WPA2 password: find the network in my device, connect... ok, but no DHCP IP address and no internet :(

The router is a little Ubiquiti Edgerouter X connected to the POE switch (a Zyxel 
GS1008HP, unfortunately not manageable in Nebula), but hands out DHCP addresses to all AP (and also to my laptop, if I cable connect to the switch). 

Why isn't the wifi network giving the client a DHCP address? 
I also tried to set a static IP in the same subnet, but it doesn't work either... 

Do I need a Zyxel router? ?_? I can't find the "WAN" setting anywhere in Nebula... how can I set what my main network is and what the wifi LAN I want to be? 

May be it's something trivial, I'm not a big expert... any hints?  

Best Answers

  • Zyxel_HsinBo
    Zyxel_HsinBo Posts: 140
    5 Answers First Comment Friend Collector First Anniversary
     Zyxel Employee
    Answer ✓

    We have checked the diagnostics of one of your AP.
    According to your settings, the AP and the SSID clients use two different subnets.
    The AP management VLAN is VLAN1 untagged, with the subnet
    The VLAN settings of the SSID with the value 100.

    May we know if there is a specific usage for wireless clients that need to use VLAN100?
    If not, just modify the SSID VLAN settings with the value “1”, the clients should get the DHCP IP assigned and will be able to access the Internet.

    If yes, please check both settings of your gateway and switch.
    (Check if switch ports VLAN settings are correctly set up, and ensure there is a VLAN100 interface on your gateway and VLAN100 DHCP server set up)
    Thank you.
  • Aisman
    Aisman Posts: 2
    Answer ✓
    Hi, thank you for your reply! 
    (Not sure where it comes from but anyway... nice to know!) 
    Setting VLAN tag to 100 for SSID was not intentional. Reverted to 1. 
    Everything works! 
    Thank you very much! 

    Best Wishes

Nebula Tips & Tricks