NR7101 (100ABUV6C0 with R11A07) - LTE Random Disconnects

Noddy
Noddy Posts: 23
First Comment First Answer Friend Collector First Anniversary
 Freshman Member
edited October 2022 in Mobile Broadband
Hey, has anyone been having problems with the latest Firmware and Modem Code File?  Since updating I've been having random drops.  In the log, CELLWAN reports "RILCMD: Reset LTE module because of timeout flag is 1" and "RILCMD: generic_tx_timeout_recover() RESET LTE module wait for 25 secs."

At first I thought it was a problem with my Asus XT12 Mesh WiFi units as sometimes you have to change the "WAN DHCP Query Frequency" to "Continous" in order to stop random WAN disconnects.  However this is not the case here - after investigation the drop is occuring on the NR7101 LTE module.  And the Asus logs match the NR7101 for the time of the drop reporting "kernel: eth0 (Int switch port: 5) (Logical Port: 5) (phyId: 11) Link DOWN."

This is purely the NR7101 dropping the connection.  1 - 2 minutes later the log will show "RILCMD: set_LTE_connection_status: Up" and "esmd: LTE WAN wwan0 link up".

Signal quality isn't an issue.  5G speeds are fine.  The unit has been in situ for a long time.  Uptime is just 4 days.  This has all started since updating to V6 and R11A07.

I'm yet to perform a factory reset of the NR7101.  But wondered if anyone else is seeing this issue?

Thanks.



All Replies

  • Noddy
    Noddy Posts: 23
    First Comment First Answer Friend Collector First Anniversary
     Freshman Member
    Well 4 days since factory reset and so far no further LTE module disconnects on the NR7101.  I think going forwards if the FW is updated - then do a reset, regardless.  Safest way.

Consumer Product Help Center