HP printer connects to another access point and printing is not possible anymore

Options
PimK82
PimK82 Posts: 49  Freshman Member
10 Comments Friend Collector
edited November 2023 in Nebula

Hello,

I've noticed that our business HP printer (Officejet Pro 9022e) sometimes roams to another access point (nr. 2). This happens for instance when the closest access point (nr. 1) has become unavailable. When all the workstations are connected to access point nr. 1, they can't print unless I powercycle the printer. After the powercycle the printer connects again to access point nr. 1 and everyone can print again. The printer has a static IP address btw.

The setup is as follows:
- 2 access points Zyxel NW50AX with forwarding mode “Local bridge”,
- connected to a switch Zyxel GS1200-8HP v2,
- connected to a modem from a local Dutch provider, which is DHCP server.

How can I setup the wireless network that the printer is always available indepently on which access point it is connected?

Thanks!

Best Answers

  • Zyxel_Nami
    Zyxel_Nami Posts: 518  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Dear @PimK82

    To further troubleshoot the issue, I recommend checking the following settings on the switch: 

    • IGMP Snooping: In case that the printer uses MDNS to query DNS, then please make sure IGMP Snooping is disable on the switch to prevent it from dropping multicast packets. 
       
    • Port Isolation: You mentioned that when a workstation is connected through a cable with the switch, he can't find the printer that is connected to WiFi. We assume that the Port Islation may be enabled, so please check it at the following direction: 
      Port > Advanced Setting at the bottom of the page. 
       

    Additionally, it would be helpful to know what version of firmware your switch is running. To find this information, go to System > System Information in the switch's web interface. 

    Alternatively, in order for us to investigate in depth this issue, could I send you the private message to ask about the configuration file that I can use for reproducing the environment?

    Best Regards,

    Nami 

    Zyxel Nami

  • Zyxel_Nami
    Zyxel_Nami Posts: 518  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited March 2023 Answer ✓
    Options

    Hello @PimK82

    I'm glad to hear that the printing issue has been resolved.

    Enabling assisted roaming on the Nebula access points means that IEEE 802.11k/v is activated. This allows end devices to request 802.11k neighbor lists from the access point, which then sends a list of nearby access points along with their operating channels. Also, 802.11v-capable clients on the 2.4 GHz band can receive messages from the access point to steer them to the 5 GHz band for better performance. 

    This function helps to provide seamless wireless connectivity when moving between access points, so the wireless connectivity is more stable. 

    Please note that roaming is the behavior of the end devices, and the decision to roam to another access point with a better signal is also made by the end devices with help from the current access point. 

    Please feel free to contact us if you have further concerns.

    Nami

    Zyxel Nami

All Replies

  • mMontana
    mMontana Posts: 1,337  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    IMO serveral points could be evaluated and managed.

    1: printer is ethernet cable capable. The use of network cable should ease lot of issues
    2: I don't know if the two APs are aware “each other” and can cooperate for manage roaming devices
    3: in Windows, usually HP devices are be configured or via WSD or via HP TCP IP port. Both port type don't manage that well the change of connection. Nice thing about WSD and HP TCP/IP port that manage nicely IP address change but… not that seamlessly.

    All things considered, maybe you shoul took this path:

    1: reserve IP Address for the printer on your Dutch ISP router (only for wireless connection)
    2: ad a TCP/IP Port on windows computer (at least one for test), and associate it with all the devices you're using
    3: test how this setup works for you when the closest AP goes down for reboot, upgrade, whatever.

    If this setup works better than your current, extend the port configuration/assignation on all your Windows devices. For Android and iOS… port issue should not matter that much. Android usually rely on IPP, MacOS/iOS on Bonjour/mDNS.

  • Zyxel_Nami
    Zyxel_Nami Posts: 518  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited March 2023
    Options

    Hi @PimK82

    Thank you for reaching out regarding your HP printer's connectivity issues with NWA50AX access points.  

    Based on your description, it sounds like the printer may not be roaming properly between the access points. To resolve this issue, we suggest you to check and adjust some of the settings on Switch and Access Points as well. Here are a few points: 

    1. Since you mentioned that when the printer connects to AP 1, everyone can print normally, we assume that AP 1, the printer, and other end devices are in the same VLAN/subnet, or if they are in the different VLAN/subnet, there are no routing policies on your ISP modem that restrict different VLANs routing. Based on this assumption, it should work normally when the printer roams to AP 2 while other devices still connect to AP 1. Thus, we suggest checking whether the switch allows VLAN tagged out of AP 2 that broadcasts same SSID or not. 
    2. Enabling band steering on access points can help encourage your other devices, such as mobile phones and laptops, to connect to the less crowded 5GHz band. This can help ensure that the 2.4GHz band is left available for your printer. 
      Menu path: Access Point > Configure >> SSID Advanced settings > Advanced settings > Enable Band select as below screenshot: 
    3. If you continue to experience connectivity issues after implementing above checks, we suggest you to enable Zyxel support for us to investigate and provide you the quick support. It is located at Help >> Support request >> enable Invite Zyxel support as administrator, and please remember to provide us your Organization and Site via PM. 

    By the way, as @mMontana mentioned, the printer tends to connect via an Ethernet cable. You may want to consider connecting your printer to your network via Ethernet instead of WiFi to ensure a more stable connection. 

    I hope these steps help resolve your issue, and please don't hesitate to reach out for further assistance. 

    Nami

    Zyxel Nami

  • PimK82
    PimK82 Posts: 49  Freshman Member
    10 Comments Friend Collector
    Options

    Hi @mMontana & @Zyxel_Nami,

    Thanks for helping!

    I could connect the ethernet cable to the printer, but unfortunately I would need a cable of 20m which will be going through the office. Wireless is the best solution for our situation.

    The settings on Windows I would rather not change to much, only when it's really necessary.

    @Zyxel_Nami

    1. Both of the AP's are on VLAN 1 through the same SSID. Should normally work perfect when someone roams indeed.
    2. Band steering is off due to the fact that we have a seperate 2,4Ghz SSID. Printer is 5Ghz capable and is only connected to that frequency. Printer is setup to use ONLY the 5Ghz in the settings, it has been reset to factory defaults as well to make sure it was not the printer itself which is causing the issues.
    3. I have enabled it for you.

    Some extra information. I just noticed that when a workstation is connected through a cable with the switch, he can't find the printer. I need to test it a little more, but to be sure I've added a screenshot of the VLAN serttings of the switch below:

  • Zyxel_Nami
    Zyxel_Nami Posts: 518  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options

    Dear @PimK82

    To further troubleshoot the issue, I recommend checking the following settings on the switch: 

    • IGMP Snooping: In case that the printer uses MDNS to query DNS, then please make sure IGMP Snooping is disable on the switch to prevent it from dropping multicast packets. 
       
    • Port Isolation: You mentioned that when a workstation is connected through a cable with the switch, he can't find the printer that is connected to WiFi. We assume that the Port Islation may be enabled, so please check it at the following direction: 
      Port > Advanced Setting at the bottom of the page. 
       

    Additionally, it would be helpful to know what version of firmware your switch is running. To find this information, go to System > System Information in the switch's web interface. 

    Alternatively, in order for us to investigate in depth this issue, could I send you the private message to ask about the configuration file that I can use for reproducing the environment?

    Best Regards,

    Nami 

    Zyxel Nami

  • PimK82
    PimK82 Posts: 49  Freshman Member
    10 Comments Friend Collector
    Options

    Thanks @Zyxel_Nami

    I think I've found the issue. It's probably due to the port uplink setting you mentioned in your latest response. By accident I reset the switch on Friday. After I've set the IP address and router again, all devices could connect to the printer through every port they were on. Probably I've set the uplink port to 1 (connection to the modem) thus limiting communication between the other ports on the switch. I did not change anything else in the past if I remember correctly.

    I will do another check tomorrow, when I'm in the office again. I will let you know if it is fixed permanently.

  • PimK82
    PimK82 Posts: 49  Freshman Member
    10 Comments Friend Collector
    Options

    Hi @Zyxel_Nami

    I can confirm that the issue with printing is resolved. Everyone can print from both AP's and the network cable. The setting of the port uplink on the switch was the issue.

    What I noticed this morning is that I lost connection when roaming to the other AP. I've turned on assisted roaming and I think this resolved that issue. Is assisted roaming necessary?

  • Zyxel_Nami
    Zyxel_Nami Posts: 518  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited March 2023 Answer ✓
    Options

    Hello @PimK82

    I'm glad to hear that the printing issue has been resolved.

    Enabling assisted roaming on the Nebula access points means that IEEE 802.11k/v is activated. This allows end devices to request 802.11k neighbor lists from the access point, which then sends a list of nearby access points along with their operating channels. Also, 802.11v-capable clients on the 2.4 GHz band can receive messages from the access point to steer them to the 5 GHz band for better performance. 

    This function helps to provide seamless wireless connectivity when moving between access points, so the wireless connectivity is more stable. 

    Please note that roaming is the behavior of the end devices, and the decision to roam to another access point with a better signal is also made by the end devices with help from the current access point. 

    Please feel free to contact us if you have further concerns.

    Nami

    Zyxel Nami

Nebula Tips & Tricks