Challenges while installing MetaRepository on NSA320s

Options
2»

All Replies

  • hacko
    hacko Posts: 2
    First Comment
    Options

    I have the same issue with a NSA325 FW 4.81 and can provide the details you have.

    What really looks strange are the .list files. It first contains package names, then part of a version, part of an url and then the file names. Furthermore the first package is without indendation. Looks pretty strange but idk what it should look like. Do you need more information?

    cat request | sh -x pkgcgi.cgi inetd-server > out.log
    dirname pkgcgi.cgi
    RELDIR=.
    CONFIG=/usr/local/zy-pkgs/etc/MetaRepository.conf
    . /usr/local/zy-pkgs/etc/MetaRepository.conf
    SCRATCH=/i-data/md0/admin/zy-pkgs/MetaRepository
    LISTEN_AT=59999
    NOPASV=false
    NOCURL=false
    cat
    '[' inetd-server = inetd-server ']'
    ParseInput
    '[' -f /tmp/MetaRepository.log ']'
    local request=
    read line
    '[' ' ' '>' 'GET /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz HTTP/1.0' ']'
    echo GET /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz HTTP/1.0
    grep HTTP
    grep GET
    echo GET /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz HTTP/1.0
    awk '{print $2}'
    request=/NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz
    echo /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz
    sed 's|/../|/|g'
    request=/NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz
    read line
    '[' ' ' '>' '' ']'
    '[' /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz '!=' '' ']'
    InvokeEngine /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz
    dirname /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz
    local path=/NSA325-v2/4.80/zypkg
    basename /NSA325-v2/4.80/zypkg/ZYPKG_INFO.tgz
    local file=ZYPKG_INFO.tgz
    '[' ZYPKG_INFO.tgz = ZYPKG_INFO.tgz ']'
    ZYPKG_INFO_tgz /NSA325-v2/4.80/zypkg
    exec

    out.log
    reada /i-data/md0/admin/zy-pkgs/MetaRepository/http___zyxel.diskstation.eu_Users_Mijzelf_zypkg-repo_fw4_stock_packages_/i-data/md0/admin/zy-pkgs/ZYPKGS
    reada /i-data/md0/admin/zy-pkgs/MetaRepository/http___zyxel.diskstation.eu_Users_Mijzelf_zypkg-repo_fw4_/i-data/md0/admin/zy-pkgs/ZYPKGS
    HTTP/1.0 200 OK
    Cache-Control: private
    Server: bash/2.0
    Connection: Close
    Content-type: application/gzip �� d�Wmo�6�g����mbJ�%���lC…

  • Mijzelf
    Mijzelf Posts: 2,682  Guru Member
    Community MVP First Anniversary 10 Comments Friend Collector
    Answer ✓
    Options

    OK, found it. For some reason the new server does unix<>dos translation when using ftp. And so the ZYPKGS were screwed up.

    It should work now. If it still doesn't, remove the contents of \\<nas>\admin\zy-pkgs\MetaRepository\ and retry.

  • hacko
    hacko Posts: 2
    First Comment
    edited March 2023
    Options

    Awesome! That did the trick, thank you.

    I needed to remove the admin/zy-pkgs/MetaRepository, disable and enable the MetaRepository and fetch Package List twice. Then all the packages were available.

    Thank you, for your passion!

  • kemes
    kemes Posts: 11
    First Comment
    Options

    Thank you Mijzelf for solving the issue!

Consumer Product Help Center