ISP account l2tp don't stay Nailed-Up when disconnected bug

PeterUK
PeterUK Posts: 2,704  Guru Member
First Anniversary 10 Comments Friend Collector First Answer

This bug happens on USG60W V4.73(AAKZ.0)ITS-22WK50-r106743 but likely happens on newer models.

Testing by privatevpn.com the connection for PPP of lt2p goes up and after being idle for some time disconnects and does not reconnect putting Connectivity Check on makes it stay up for longer but still this disconnects and does not reconnect with Nailed-Up.

«1

All Replies

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 752  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @PeterUK ,

    Greeting forum, did you mean after install 4.73 wk50 l2tp cannot connecte anymore ?

    I can vertiy L2TP can naild-up on FLEX series with 5.35 version .

    Thank you

  • PeterUK
    PeterUK Posts: 2,704  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited April 2023

    I get termination request which stops Nailed-Up from reconnecting

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 752  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @PeterUK ,

    Thanks your feedback, I used my USG(4.73wk50) and Flex(5.35) to connect my private L2TP.

    It have been connected more than 2 hours without disconnecting .

    Could you use the Flex/ATP series for the testing ?

    Thank you

  • PeterUK
    PeterUK Posts: 2,704  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer

    But what I'm saying is the other end disconnects me by sending a termination request are yo able to test that?

    Also how do you setup a plain L2TP thats the remote end? As I connect to privatevpn.com for the remote end. Thanks

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 752  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @PeterUK,

    I built L2TP service on CentOS as my prviate L2TP server. And connect it by FLEX and USG.

    If the issue occur on FLEX/ATP, please kindly provide packet captured for us.

    Thank you

  • PeterUK
    PeterUK Posts: 2,704  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited April 2023

    Something has changed now when I get the termination request the USG reconnects where as before shown above with what the other end sent caused the USG to not reconnect.

  • PeterUK
    PeterUK Posts: 2,704  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited April 2023

    and now its back guess I do a longer packet capture and test on the FLEX200

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 752  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited May 2023

    Hi @PeterUK ,

    Thanks your feedback.

    Please kindly provide packet captured if the issue persist on FLEX200.

    Thank you

  • Zyxel_Kevin
    Zyxel_Kevin Posts: 752  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer

    Hi @PeterUK ,

    Thanks your detail reproduce steps. My l2tp server is under 10.214.48.30 with PNAT.

    After I stopped xl2tpd service, server sent the termination request. I then re-enable xl2tp service and L2TP client (my flex: 10.214.48.17) send the Start-Control-Connection-Request after 27 sec, L2TP connected again without any action.

    From your packets, It seems packets not captured from FLEX because MAC is from Cisco.

    Please captured related packets on Firewall interface. Thank you

Security Highlight