VMG3925 B10C Cellular Backup problem

Prior to lockdown I was supplied with a VMG3925 B10C by my ISP. It became the centre of my little network getting internet access through ADSL. Since lockdown ended, I travel much more, but only need to use my home network for a couple of months at a time; an ADSL connection does not look viable. I am hoping to use a 4G dongle as my connection to the internet and connect it to my little network.

To test out my idea, I bought a 4G dongle, a USB (female)/ethernet connector, and a SIM card. The dongle appears to be working fine when I have plugged it into a USB hub of a Windows 10 laptop, and also a desktop running Linux Mint. It also provides Wifi hub which works.

When I have plugged into the USB hub of the VMG3925 B10C I get mixed results, its USB light is lit, the Wifi hub works, but according to the web interface, there is nothing attached to the USB interface. I have configured the Cellular Backup page correctly, I believe. I have read the manual and tried all the troubleshooting suggestions.

Using the USB/Ethernet adapter I bought, I have tried to connect my dongle to the ethernet ports on all Windows, Linux and the router, this does not work at all.

Any help will be much appreciated.

Thanks

All Replies

  • Liba
    Liba Posts: 107  Ally Member
    First Anniversary 10 Comments First Answer

    Maybe VMG3925 B10C not support this USB hub and 4G dongle. But recommend that you can contact your ISP for ADSL connection problem.

Consumer Product Help Center