Problem Wifi Calling

Options
PI71850
PI71850 Posts: 6
First Anniversary First Comment

Hi,

Sorry for my bad english.

I'm a problem with a smartphone to Wi-fi calling.

We installed a Zyxel wifi hotspot (model: NWA1123ACv3, firmware version 6.3).
On a Samsung Galaxy A52s 5G, Wifi calling does not work with this hotspot.
it works on other wifi delivered by other hotspots (not zyxel)

Wifi calling from other smartphones (samsung galasy s23, iphone) works on the wifi zyxel hotspot

I tried forgetting Wifi, restarting the phone, turning off data roaming, updating Play store apps, updating the phone (version 5.1 One UI), testing in flight mode with wifi, disable 5Ghz and 6Ghz on the hotspot

I can't find a solution anymore.
Can you help me please ?

Best regards

Thomas

All Replies

  • Zyxel_Kay
    Zyxel_Kay Posts: 598  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @PI71850

    To address your issue, we would like you to perform the following troubleshooting steps:

    1. Update your AP NWA1123ACv3 to the latest firmware version 6.55(ABVT.1)C0 .
    2. Check if the Wi-Fi Calling function is enabled on your Samsung Galaxy A52s 5G. You can find this option in Settings > Connections > Wi-Fi Calling.
    3. If the previous steps don't resolve the issue, try resetting the network settings on your Samsung Galaxy A52s 5G. To do this, go to Settings > General management > Reset > Reset network settings. This will reset your device's network settings, and you will need to reconnect to the network.

    If the problem persists, please provide us with the following information to better understand your problem:

    1. Can your Samsung Galaxy A52s 5G connect to the internet through this AP’s SSID?
    2. Please screenshot your device's software information (including: One UI version, Android version, Baseband version, Build number, and etc,) and provide us through a private msg. This will help us replicate the problem in our office and assist you further.

    Kay

  • PI71850
    PI71850 Posts: 6
    First Anniversary First Comment
    Options

    Hi,

    Thank you for your prompt answer.
    I just updated the wifi hotspot. I hadn't seen that it wasn't the latest version.
    The wifi calling function is activated :


    Normally, there should be the small wifi calls icon at the top but it does not appear on this access point

    The phone has Internet access on the same SSID. Calls with Wathsapp and Google Hangouts work on this same SSID.

    I ask the user to test again.

    If it still does not work, I will send you the phone information.

    Best regards

  • Zyxel_Kay
    Zyxel_Kay Posts: 598  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    edited May 2023
    Options

    Hi @PI71850

    In addition to enabling the Wi-Fi Calling setting, please switch your Calling Preference to "Wi-Fi preferred" as shown in the screenshot below:

    After completing the set up, the wifi calls icon should be at the top right corner.

    If this solution doesn't resolve the issue, please provide us with your device's software information through a private message. This information will help us further assist you.

    Kay

    Kay

Nebula Tips & Tricks