LTE5398-M904 5GHz wifi can't connect after a while

Nux
Nux Posts: 1
edited August 2023 in Home Router

Hello, I've bought a LTE5398-M904 router.

I've set up everything correctly, including the 2.4GHz and 5GHz WiFi networks.

After that I've connected to the 5GHz network an Asus RT-AX58U router in repeater mode, to use it as wifi extender, with different SSIDs for both the 2.4 and 5 GHz networks.

After a few minutes no device can connect to the Zyxel 5GHz network, even the devices already connected can't access internet anymore, including the Asus router. New devices who need to connect sometimes show the 5GHz network but can't connect, some other times they can't find it (even manually searching the SSID).

The issue seems to show up when I connect the Asus router as extender, tried to connect both with a dynamic and a static IP, same issue.

Tried then to use only a specific channel on the Zyxel side (5GHz channel 40 only), same issue.

Both 2.4GHz network and wired continue to work fine and in the router panel there is no error log regarding the 5GHz network.

The router is on V1.00(ABQV.3)C0 firmware.

I've used my Asus router as an extender for other routers already, never had this issue.

All Replies

  • Internetheavyuser
    Internetheavyuser Posts: 75  Ally Member
    10 Comments Friend Collector First Answer

    "even the devices already connected can't access internet anymore"
    —> Did you check the internet access for the LTE5398-M904 is working correctly? How about the signal strength ?

    Does your environment have other routers ? 5GHz signal is weaker than 2.4GHz which is easily be blocked by the wall or other wireless router.
    Also check the antenna switch in the back of the device to see whether it swithc to internal.

Consumer Product Help Center