Set browser focus to 2FA prompt

Options
Lewpy
Lewpy Posts: 18  Freshman Member
First Anniversary 10 Comments Friend Collector

When the login process prompts for 2FA, could you please set the focus to the input box for the 2FA code on the web page?

So many times I have started to type in the code from my phone, only to realise that it isn't being typed in because I haven't manually selected the input box first. It's very annoying and should be a simple fix.

Side notes:

The input box should tell the web browser not to remember previous codes that have been entered, as it is completely unnecessary having a drop-down history of previous codes and potentially a security problem (if code and time of code can be determined).

The 2FA prompt page should only come up in the language of the web browser. I get occasional prompts come up in random languages!

1 votes

Active · Last Updated

Comments

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,759  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Lewpy,

    May I know what you mean is this login page, right?

    Zyxel Melen

  • Lewpy
    Lewpy Posts: 18  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    Hi Melen,

    Yes, that is the initial login screen, but if you have 2FA enabled then the next screen is this

    And it is this one where the cursor doesn't default to being actually in (focused) on the "Enter Code" box. So you reach for your phone and start typing the code, but it doesn't go in the box until you manually click the mouse in to the box.

    Most 2FA prompts I use at work or at home default to being ready for you to type the code without needing to click in the box first.

    It is also this input box that remembers previous codes in the browser (there should be HTML code to tell the browser it is a password prompt or something like that, so it doesn't remember the previous codes), and also the text sometimes comes up in a foreign language (to me): I think I had Italian last week!

    Thanks,
    Lewis.

  • Lewpy
    Lewpy Posts: 18  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    Hi Melen,

    I just logged out and in again, and got the prompt in German this time!

    I've also shown the browser "Saved data" list, which is unnecessary (the codes keep changing) and at worst a security risk (history of previous codes & times could potentially allow prediction of future codes)

    Thanks,

    Lewis.

  • Lewpy
    Lewpy Posts: 18  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    Today I appear to be have Chinese (according to Google Translate, so apologies if I have identified it incorrectly)

  • Zyxel_Melen
    Zyxel_Melen Posts: 1,759  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi @Lewpy,

    Thanks for your feedback.

    Let me summarize your request:

    1. Set the focus to the input box for the 2FA code on the web page.
    2. The input box should tell the web browser not to remember previous codes that have been entered.

    We have listed these requests, and we will evaluate them.

    For the problem of displaying the wrong language, the fixing scheduled is before the end of September. I apologize for the late update and any inconvenience we caused.

    Zyxel Melen

  • Lewpy
    Lewpy Posts: 18  Freshman Member
    First Anniversary 10 Comments Friend Collector
    Options

    Hi Melen,

    Yes, that is a correct summary.

    Thanks for the update on fixing the language of the 2FA page. While it is clearly a bug, I do find it quite an amusing one: today I was whisked off to Italy again 😀

    Thanks,

    Lewis.

Nebula Tips & Tricks