[NEBULA] When using the Click to Continue option in Captive Portal, Acknowledgment page slow?

David_Charron
David_Charron Posts: 20  Freshman Member
First Anniversary 10 Comments Nebula Gratitude
edited April 2021 in Nebula
When using the Click to Continue option in Captive Portal, I am hearing a lot of complaints that the Acknowledgement page takes a long time to come up in order to agree.  Is there a setting that I might be missing?
«1

All Replies

  • Zyxel_Freda
    Zyxel_Freda Posts: 397  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Hi David,

    I tested in my lab and it's about 5-6 seconds to pop-up the captive portal page.
    However, we also tested 2.4GHz only and it took more time to pop-up the portal page because there're many 2.4GHz interference in my environment.
    So, may I know the customers used connect to the AP via 2.4GHz or 5GHz, were their signal good or bad when connected, or were they far away from the connected APs?
  • David_Charron
    David_Charron Posts: 20  Freshman Member
    First Anniversary 10 Comments Nebula Gratitude
    It's difficult to say which one they are connecting to because the Band it is set to Concurrent Operation.
    They were not far away from the APs, but again difficult to say.  For my experience, I was close to one with a strong signal.

    Thanks.

  • Zyxel_Freda
    Zyxel_Freda Posts: 397  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Hi David,

    Was the page changed other pictures or modified before using? Or, you just use a default page?
    After you logged in and went to Internet, is the speed still slow?
    Is it possible to set a SSID to broadcast in 5GHz only for checking if it's caused the interference?
    Thanks.
  • David_Charron
    David_Charron Posts: 20  Freshman Member
    First Anniversary 10 Comments Nebula Gratitude
    The page is a one page custom written page with a logo at the top. 
    Once logged in, the speed is fine. 

    I can can try setting it to 5G and see what happens. 

    Thanks. 

  • Zyxel_Freda
    Zyxel_Freda Posts: 397  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Hi, 

    There's the other possibility about Captive Network Assistant (CNA).
    When the client connects to AP, the client has CNA mechanism to load the captive portal and  it's very often we find it sometimes delay to load the portal or not loading at all. 
    In this situation, we suggest to perform "forget the network" on the SSID, "switch off/on the WiFi", or reboot the client.
    This way, we can exclude issues on the phone itself.
    Thanks.
  • David_Charron
    David_Charron Posts: 20  Freshman Member
    First Anniversary 10 Comments Nebula Gratitude
    If I can catch someone who is having the issue at the moment, I will certainly perform that procedure.
  • Zyxel_Freda
    Zyxel_Freda Posts: 397  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Sure. Please do not hesitate to let us know if you have information.  :)
  • David_Charron
    David_Charron Posts: 20  Freshman Member
    First Anniversary 10 Comments Nebula Gratitude
    So I have been able to track a few people down and performed the procedure, it was still slow 2 out of 3 times.
    Also found out some new information,  it seems that Android phones have the most trouble that it will not even produce the Acknowledgement page, it gives an error on the page.

    Any thoughts on that?

    Thanks.
  • Zyxel_Freda
    Zyxel_Freda Posts: 397  Zyxel Employee
    First Anniversary Friend Collector First Answer First Comment
    Hi David,

    Would you share the error message or screenshot for us?
    Thanks.
  • RUnglaube
    RUnglaube Posts: 135  Ally Member
    First Anniversary Friend Collector First Answer First Comment
    Have you checked the LANs settings? maybe some issues with VLAN routing or something like that
    "You will never walk along"

Nebula Tips & Tricks