How to fix "WPA3 connection required" message on Samsung Galaxy A51 with Android 13?

ralluffie
ralluffie Posts: 2
Friend Collector First Comment
edited December 2023 in Home Router

I have a Zyxel EX5601-T1 which is set on WPA3/WPA2. My Samsung Galaxy A51 with Android 13 won't connect automatically with the modem and shows the message "WPA3 connection required". I found solutions online that said I had to reset all network settings on my phone but that didn't work. When I tap de wifi-conncetion on my phone manually i does connect. Does anyone know how to fix this so it will connect automatically on the WPA3? Thank you.

All Replies

  • tonygibbs16
    tonygibbs16 Posts: 803  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited December 2023

    Hello @ralluffie

    Welcome to the forum.

    The user guide at https://download.zyxel.com/EX3301-T0/user_guide/EX3301-T0_V5.15_5.70.pdf covers the EX5601-T1 as well.

    There are instructions about how to configure WPA3 in section 9.2, see below extract of the start of the instructions for setting WPA3.

    More instructions follow in the user guide.

    I hope that this is helpful.

    Kind regards,

    Tony

  • Hi @tonygibbs16, Thank you for your reply. I know about the manual and about the settings. But the message "WPA3 connection required" can't get fixed by the manual and exactly seem to be happening to quite some users. When you google it, you'll notice it comes up as one of the first suggestion. I read some people contacted Zyxel and got the suggestion for an specific update for their modem. So I kinda was hoping for something else then a reference to the manual. :) Hope you or someone else has another suggestion. Thank you.

Consumer Product Help Center